1. Introduction 1

1.1 Purpose 1
1.2 ARK Overview 1
1.3 Intended Audience 1
1.4 Conventions 1
1.5 Manual Organization 2
1.6 Further Reading 2

2. The ARK Concept 3

2.1 Introduction 3
2.2 Product Component Libraries 3
2.3 Controller Components 4
2.4 Applications 4

3. ARK Software Roadmap 5

3.1 Introduction 5
3.2 ARKbase 5
  3.2.1 Installation 5
  3.2.2 Development Tools 5
  3.2.3 Manufacturing Tools 6
  3.2.4 Configuration Tools 6
  3.2.5 File Formats Associated with ARK 6
3.3 ARKsdk 7
3.4 ARKbase for Windows CE 7
3.5 ARKonline Library Manager 7
3.6 SOUNDFIT 8
3.7 ARK Release Notes 8

4. Connecting to the Device 9

4.1 Introduction 9

TABLE OF CONTENTS
# 7.3 Viewing Generated Coefficients

# 7.4 Transferring Coefficients

# 7.5 Filters Graph

# 8. Feedback Path Measurement Tool

## 8.1 Introduction

## 8.2 Measuring Feedback Paths

### 8.2.1 Connecting to the Device

### 8.2.2 Setting Feedback Path Measurement Parameters

### 8.2.3 Feedback Path Measurement Routine

### 8.2.4 Generating FFT Data and Graphing

## 8.3 Feedback Path Measurement Principles

### 8.3.1 Amplifier Configuration

### 8.3.2 Ambient Noise

### 8.3.3 Settling Time

### 8.3.4 Transducer Saturation

## 8.4 Understanding Feedback Path Data

## 8.5 Product Library Requirements

# 9. Calibration/Configuration Software

## 9.1 Introduction

## 9.2 Setup

## 9.3 Configuration Tools

### 9.3.1 Workstation Manager

### 9.3.2 Frye Configuration Tool

## 9.4 CalConfig and the IDS

### 9.4.1 Calibration Setup in the IDS

#### 9.4.1.1 General Tab

#### 9.4.1.2 Sensitivity Tab

#### 9.4.1.3 Volume Control Tab

#### 9.4.1.4 Telecoil Tab

#### 9.4.1.5 Directional Tab

#### 9.4.1.6 Trimmers Tab
10.5.1 Adding a Microphone or Receiver ............................................ 93
10.5.2 Copying a Microphone or Receiver ........................................ 95
10.5.3 Editing Microphones and Receivers ..................................... 96
   10.5.3.1 Viewing a Microphone or Receiver ................................. 97

10.6 Additional Features ................................................................. 98
10.6.1 Setting Permissions ............................................................ 98
10.6.2 Saved vs. Unsaved Items .................................................... 99
1

Introduction

1.1 PURPOSE


While this manual introduces all of the ARK components, it provides details only for the ARKbase™ starter kit, which can also be applied to ARKbase for Windows CE, and the ARKonline® Library Manager. All other ARK components are fully documented elsewhere as specified in the applicable section.

1.2 ARK OVERVIEW

ARK is a set of software building blocks that reduces hearing instrument fitting software development time. The free ARK software tools allow you to evaluate, design and customize, and calibrate and configure ON Semiconductor preconfigured DSP products. Then you can easily integrate your products into existing fitting software tools.

The ARK framework uses Microsoft's Component Object Model (COM) technology, also known as ActiveX®. ARK-based applications can be developed in virtually any language that supports 32-bit Windows® operating systems (Windows XP, Windows Vista, Windows 7 and Pocket PC platform). The ARK libraries were developed using C++ and the sample applications are typically developed using Visual Basic 6. The set of free ARK components and sample applications with source code, called ARKbase and ARKsdk™, is available on the ARK web site: http://ark.sounddes.com.

1.3 INTENDED AUDIENCE

The ARK User's Guide is written for people who are designing and manufacturing hearing aids using preconfigured DSP products from ON Semiconductor.

1.4 CONVENTIONS

The following special fonts are used in this manual to signify particular types of information:

- **monospace font** Commands and their options, file and path names, error messages, code samples and code snippets.

- **mono bold** A placeholder that represents where you would specify the appropriate information. For example, you would replace `filename` with the actual name of the file.

- **bold** Menu names, menu items, and text that is displayed on the screen.

- **italics** The name of a manual or an emphasized word.
1.5 MANUAL ORGANIZATION

The ARK User’s Guide contains the following chapters:

- **Chapter 1: Introduction**, describes the purpose of the manual, a brief description of the ARK, the intended audience, the book organization, and lists related documents.
- **Chapter 2: The ARK Concept**, provides an overview of the purpose of the ARK software, and the main components of the ARK framework.
- **Chapter 3: ARK Software Roadmap**, describes the free tools provided with ARK, the purpose of each of the tools, and how they relate to each other.
- **Chapter 4: Connecting to the Device**, explains how to connect an ON Semiconductor preconfigured product to your computer and begin communication through the ARK tools.
- **Chapter 5: Interactive Data Sheet**, describes the IDS engineering tool.
- **Chapter 6: Modeler**, describes the capabilities of the Modeler tool and how it works in conjunction with the other design tools provided with ARK.
- **Chapter 7: Filter Designer Plus**, details how to design filters for use with ARK product component libraries.
- **Chapter 8: Feedback Path Measurement Tool**, provides information on how to measure the Feedback path on a connected device and interpret the results.
- **Chapter 9: Calibration/Configuration Software**, describes the CalConfig application and how to use the tool for manufacturing hearing aids containing ON Semiconductor preconfigured products.
- **Chapter 10: ARKonline**, describes the ARKonline web-based tool available to hearing instrument manufacturers for customizing and building product component libraries.

1.6 FURTHER READING

For more information, refer to the following documents:

- *Application Resource Kit Programmer’s Guide* (soon to be available)
- *Parameters* information note (see the information note for your product)
- *Programming System Options for Sound Design Technologies DSP Hybrids* information note

2.1 INTRODUCTION

The Application Resource Kit (ARK) is a set of software building blocks that works behind the scenes to make it easier to develop fitting software. *Behind the scenes* means that it is not part of the user interface—audiologists and dispensers are probably not aware of it and would likely only interact with the parameters that are exposed through the fitting software.

ARK is intended to significantly shorten the software development time required to add new hearing instruments to a fitting module or standalone fitting software. It simplifies or eliminates the repetitive tasks of programming different types of controller chips and measuring hearing aid performance curves. This allows more time for the fitting software development team to focus on innovative user interfaces and fitting methodologies.

2.2 PRODUCT COMPONENT LIBRARIES

Product component libraries are collections of products and have one interface for every product. Products can be hybrids that input and output electrical signals, or hearing aids complete with shells, tubing, and transducers. Product component libraries handle the parameter mapping and generating data for characteristic curves.

A product component helps in plotting characteristic curves by calculating the output for given input levels, frequencies, and product parameter settings.

As a first approximation, the manufacturer can combine an electrical device model with microphone and receiver models (which would correspond to the acoustic input model and acoustic output model, respectively). The manufacturer can then take several measurements of actual assembled hearing instruments to refine the acoustic models. A key goal of ARK is to assist manufacturers in the rapid development of new products by removing the requirement to measure acoustic curves for every parameter combination.

Product component libraries allow manufacturers to combine multiple product components into a single dynamic-link library (DLL) for easy distribution. Manufacturers might want to combine products into libraries by product line, or combine their entire product family into a single library. For example, ARKbase includes an ON Semiconductor RHYTHM™ library containing multiple product components with varying parameter sets. ON Semiconductor has developed a library management tool, ARKonline, that assists developers with combining compiled electrical models, transducer models, parameter maps, and fitting support algorithms for multiple products into a library. These capabilities allows manufacturers to create a single library for one hybrid with multiple products that account for various acoustic setups (different transducer models, shells and tubing) in your product line.
2.3 **CONTROLLER COMPONENTS**

Controller components contain the knowledge necessary to communicate with preconfigured DSP controllers through programming boxes such as HI-PRO. Typically, there is one component per programming box, with each component supporting multiple controller chips.

2.4 **APPLICATIONS**

ON Semiconductor provides several complete applications to assist with the engineering and manufacturing of ON Semiconductor preconfigured products. The Interactive Data Sheet (IDS) is a sample application that includes the controller functionality, and also displays the frequency and input/output response for a selected product at the current parameter settings.
3.1 INTRODUCTION

This chapter provides a brief overview of the free software tools that are based on the ARK technology. Further details about ARKbase and ARKonline follow in the remaining chapters of this book. The other components are described in detail in separate documentation.

3.2 ARKbase

ARKbase is the ARK starter kit. It must be installed before any other ARK package. ARKbase contains all ARK components and several applications constructed using these components. It can be used to learn about ARK, to evaluate ON Semiconductor’s latest preconfigured hearing products, and to test components developed using ARKonline. ARKbase also includes software that aids in the calibration and configuration of hearing instruments at the manufacturing level. To evaluate ON Semiconductor preconfigured hearing products and explore all the benefits and capabilities that ARK tools offer, install this package.

3.2.1 Installation

To download any of the ARK software packages provided, first register for an ARKonline account. For instructions on how to register for an account, refer to Section 10.2, “ARKonline Membership” on page 83. You can then download the ARK software packages from www.sounddesigntechnologies.com.

3.2.2 Development Tools

The ON Semiconductor > ARK > Development Tools list under the Windows Start menu contains shortcuts to the programs designed to streamline the development of ON Semiconductor preconfigured DSP products.

Interactive Data Sheet This is a high-level software tool intended to familiarize you with the functionality and typical acoustical and electrical performance of ON Semiconductor preconfigured DSP products.

Modeler 2 Provided as a stand-alone program that uses an ON Semiconductor digital hybrid to extract microphone and zero-bias receiver models. Such transducer models can be used in the ARKonline Library Manager to create product component libraries.

Feedback Path Tool Uses the Feedback Canceller to measure the feedback path of a hearing aid, in-situ. From this measurement, you can determine the amount of gain that can be added to the system without causing feedback. This is useful in determining the Maximum Stable Gain frequency response. This tool requires a hybrid, such as the Rhythm R3910, with the Feedback Path Measurement firmware built-in.
Filter Designer Plus  Provides an easy method of converting analog to digital coefficients for biquad filters. Automated transfer of the coefficients to the Interactive Data Sheet (IDS) is also available in this program. A graph is displayed to show the total effect of the filters. A parametric filter section is available with amplitude, Q and frequency adjustments for six different parametric filter types.

Controller Toolbox  This tool is deprecated and will be removed from future releases of ARKbase.

3.2.3 Manufacturing Tools

ON Semiconductor > ARK > Manufacturing Tools under the Windows Start menu contains examples of calibration and configuration software used on the production floor.

The CalConfig 2 program has two main functions:

- To configure ON Semiconductor digital hearing instruments to a designed product component.
- To calibrate gain mismatches due to process variability of microphones, receivers, volume controls, trimmers and telecoils.

The CalConfig 2 program utilizes the Manufacturing Applications Resource Kit (mARK2™) Core Component included in the ARKbase package.

3.2.4 Configuration Tools

ON Semiconductor > ARK > Configuration Tools under the Windows Start menu contains programs to correctly configure your computer interfaces:

ARK Component Manager  Register DLLs downloaded from ARKonline to be used with the IDS. You can also access the tool under the Tools > ARK Component Manager menu item in the IDS.

Frye FONIX 6500 & 7000 Configuration  Allows you to set up the Frye FONIX box parameters such as the communications port to which the Frye box is connected.

MARK Conversion Tool  This tool is deprecated and will be removed from future releases of ARKbase.

Workstation Manager  Allows you to configure settings specific to a workstation, such as the stimulus and measurement devices to be used during calibration.

3.2.5 File Formats Associated with ARK

The following files contain the configuration and data required for designing and manufacturing hearing aids:
IDS file (.ids)
An IDS file is the output from the engineering work completed in the IDS. The IDS file defines all of the parameter settings, and calibration and configuration details for a selected product library. Once the product settings have been finalized in the IDS, save them to an IDS file. The IDS file can then be transferred to manufacturing and used with the CalConfig software for configuring your ON Semiconductor preconfigured devices.

Modeler File (.mlr)
A modeler file is the output from the Modeler application. The .mlr file contains the name of the microphone or receiver that was modeled, the frequency, sensitivity level, and saturation level. The set of saturation data points only appear in a .mlr file created from a receiver.

Evoke Indicators file (.xml)
EVOKE™ indicator files are created through the Evoke Editor available in the IDS. The .xml files can be saved and re-used for other products that support the Evoke feature.

Workstation Manager file (.wrk)
Workstation manager files are created using the Workstation Manager tool. The file contains various configuration settings required for running CalConfig. The file can be distributed to multiple workstations to ensure the same setup for each station in manufacturing.

3.3 ARKsdk
The ARKsdk package is for software developers and is designed to accommodate learning and understanding of the inner workings of ARK and its related technologies. For an in-depth document written for software professionals, refer to the Application Resource Kit Programmer’s Guide. The ARKsdk package is for developing software based on the ARK or mARK core components. It contains selected source code for binary files included in the ARKbase package, Params application examples in three programming languages, and all required header files.

3.4 ARKbase for Windows CE
ARKbase for Windows CE contains the core ARK DLLs compiled for the Windows CE operating system. A simple application, ParamsCE, is also included.

ARKbase for Windows CE supports multiple operating system versions and processor combinations.

For more information about ARKbase for Windows CE, see the relevant parts of this manual.

3.5 ARKonline Library Manager
The ARKonline Library Manager is a web-based interactive tool capable of building unique ARK product component libraries, and is designed to be exclusively used by hearing instrument manufacturers.
ARKonline uses the concept of libraries. A typical product component library consists of several products. The ARK product component libraries are intended to be developed by the hearing instrument manufacturer and used in the dispenser’s fitting software.

3.6 SOUNDFIT

SOUNDFIT® is an integrated hearing aid fitting software for ON Semiconductor hearing aid DSP products. SOUNDFIT enables you to utilize the latest ON Semiconductor digital technologies in your hearing aid product and easily integrate them into our user-friendly fitting software application. SOUNDFIT comes equipped with a full suite of product reference designs and user guides facilitating quick development and an early launch of hearing instruments.

Two additional software tools are available as add-ons to SOUNDFIT:

SOUNDFIT Customization Software
An add-on utility that allows customization of the SOUNDFIT fitting software with a hearing aid manufacturer's brand. The customized product can be easily redistributed with the manufacturer's products.

SOUNDFIT Config Utility
Configures preconfigured devices from ON Semiconductor with product libraries that are compatible with SOUNDFIT.

Full documentation provided with the SOUNDFIT application can be downloaded from www.sounddesigntechnologies.com.

3.7 ARK RELEASE NOTES

Release notes for the ARK software packages are available at http://ark.sounddes.com. The most current release’s bug fixes and improvements are available as well as an archive section containing release notes for past ARK software releases.

Each bug fix and improvement is categorized based on its severity level. The categories are available at the bottom of the release notes page.
4.1 INTRODUCTION

ARK software provides support for several programming boxes including HI-PRO, Microcard, and the DSP Programmer (designed and developed by ON Semiconductor). For customers registered with HIMSA, we also provide programming support for NOAHlink.

4.2 BEFORE CONNECTING

Before connecting to your device using any of the ARK applications, ensure that you have completed the following steps:

1. Physically connect your device to the host computer using a supported communication interface and protocol. For a list of interfaces and protocols supported by the ARK controller components, refer to Section 4.3, “Supported Interfaces and Protocols”.
2. Power on your device.

Once you have completed the above steps, you can connect to your device with any of the ARK applications.

4.3 SUPPORTED INTERFACES AND PROTOCOLS

The interfaces and protocols supported by ARK are listed in Table 1.

**TABLE 1: SUPPORTED COMMUNICATION INTERFACES AND PROTOCOLS**

<table>
<thead>
<tr>
<th>Interface</th>
<th>RS232</th>
<th>I²C</th>
</tr>
</thead>
<tbody>
<tr>
<td>HI-PRO</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>Microcard</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>DSP Programmer 1</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>DSP Programmer 2</td>
<td>X</td>
<td></td>
</tr>
<tr>
<td>DSP Programmer 3</td>
<td>X</td>
<td>X</td>
</tr>
<tr>
<td>NOAHlink</td>
<td>X</td>
<td>X</td>
</tr>
</tbody>
</table>

For information about enabling and disabling protocols within ARK software, refer to Section 5.3.1, “Programming Options” on page 14.

For information about programming system options for communicating with ON Semiconductor preconfigured DSP hybrids, refer to the *Programming System Options for Sound Design Technologies DSP Hybrids* information note.
This page left blank for printing purposes.
5.1 Introduction

The Interactive Data Sheet (IDS) is an engineering tool that displays the gain and output frequency responses and input/output curves for a selected product and configuration within a selected product component library. The Interactive Data Sheet works with any product component library that is registered.

The IDS is used during product development to simulate product performance, program the device and create configuration files that can be used with manufacturing software from ON Semiconductor, CalConfig. Figure 1 illustrates the IDS main window.

![Interactive Data Sheet Example](image)

5.2 Modeled Response

Several product component libraries are included with ARKbase and are intended to demonstrate the capabilities of ON Semiconductor products and provide prototype components. The models for ON Semiconductor product component libraries use the speech-weighted composite signal from the Frye FONIX 6500 analyzer unless otherwise specified. These models should be accurate for...
input levels that do not cause AGC-O compression limiting. The AGC-O compression limiting model currently affects the frequency response curve in a frequency dependent manner and is sine-wave accurate.

5.2.1 Choosing Graph Types

In the IDS, the Gain and Output graph (see the left side of Figure 2) shows the expected frequency response of the device based on the settings and transducer models used in the creation of the product. The red curve shows the expected output level of the hearing aid using the y-axis on the right side of the graph. The other curves show the expected gain performance at varying input levels using the y-axis on the left side of the graph.

![Figure 2: Correlating Input/Output Curve and Frequency/Response Curve Outputs](image)

You can view several different graph types depending on the features supported in the selected product. The selected graph type will be displayed on the right side of Figure 2. The Input/Output graph is the default. To change the graph type, choose one of the following under the Graphs menu:

- **Input/Output**
  Shows the expected input/output curves, based on the settings and transducer models used. By default, there are four curves at different frequencies (all four might be difficult to see due to overlap). The Input/Output curve is a cross section of the frequency response curve at a particular frequency.

  For example, if viewing an input/output curve at 1 kHz, a specific output level corresponds to the frequency response at 1 kHz if the output curve (red curve) has the same level selected. This can also be deduced from the gain curve by adding the input level to the gain. This is illustrated in Figure 2 for -50 dBV, corresponding to an output level of -20 dBV.

- **Input/Gain**
  Shows the expected gain levels at different input levels for various frequencies that are user-specified.

- **Polar Plot**
  Available on all products that support static directionality. On the Front End tab, set the FEMode parameter to directional to enable control of the beta value. By adjusting the Beta parameter slider on the Front End tab, you can observe the polar plot that is generated for each beta value.

- **Live Polar Plot**
  Only available when the computer is connected to an initialized device (see Section 5.3.4, “Initializing a Device” on page 16), the parameters are burned or written to the device (see Section 5.3.7, “Burning and Writing
Settings to Connected Device” on page 17), and its front end mode is set to adaptive directional or auto-ADM on the Front End tab.

To see a live display of how the polar plot is changing on your hearing aid based on the surrounding sounds, select Start in the dialog box. For adaptive directionality to work properly, the microphones must be calibrated first using the CalConfig program (see Chapter 9, “Calibration/Configuration Software” on page 61 for details). For evaluation purposes, you can freeze the polar pattern by selecting Freeze in the dialog box.

**Noise Shaping**

Only available if the Noise Insertion parameter on the Tinnitus tab is set to anything other than Off.

### 5.2.2 Graphing Options

The Gain and Output (frequency response), Input/Output and Input/Gain curves display the predicted output or gain response levels for incoming frequencies and levels respectively. The input level can be adjusted for the frequency response curve by clicking on the left-most graph and specifying the desired input level. This is analogous for the Input/Output and Input/Gain curve, by clicking on the right-most graph or by clicking the left graph and selecting the right graph tab.

The frequency response displays at most four gain curves and one output curve. Each Input/Output, Input/Gain or Frequency/Response curve can be turned on or off through the popup menu, or by clicking the color box in the legend. Figure 3 shows the color controls in the legend.

![Graphing Options](image)

**Figure 3: Graphing Options**

### 5.2.3 Composite vs. PureTone

The IDS allows you to switch between viewing the modeled response using a speech-weighted signal or a pure tone signal.

Selecting the Graphs > Speechweighted Input menu item switches the view to a modeled response that uses a composite signal. The input signal is a series of tones with the amplitudes matching the Frye speech-weighted composite signal.

Selecting the Graphs > Sine Input menu item switches the view to a modeled response that uses a pure tone signal. The input signal is a pure tone with the frequency set at the geometric/logarithmic center of the compression channel of interest.
The selected input signal has an effect on the compression and squelch thresholds that are programmed into the device. This implies that the electrical and acoustical response of the device will change once the parameters are burned to the device. The software predicts the output of the appropriate level detector, assuming the specified input signal at the specified level. This is done by multiplying the input-referred values (in linear form) by the appropriate level detector factor. The threshold calculations can then take into account the selected input signal (speech-weighted or sine), input transducer models, front-end mode, compensation filters, pre-filterbank biquads, and crossover frequencies.

5.3 COMMUNICATION

This section describes the options available when programming ON Semiconductor pre-configured devices (see Figure 4 on page 15), and how to communicate with these devices using one of the supported programming boxes. Before performing the steps below, refer to Section 4.2, “Before Connecting” on page 9.

5.3.1 Programming Options

Before beginning communication with a connected device, you must configure the options that are accessed from the Tools > Options menu item (the dialog box is illustrated in Figure 4):

Programming Box
Select the programming box to be used for communicating with the connected device.

Verify that burn operations have succeeded
When this option is selected, the controller components burn the settings to the device and then immediately read back the settings to confirm that the values burned to the device match what is being read out of the device. The communication speed of burns is slower due to the extra read.

Write to the device after every parameter or memory change
Any changes made to the parameter settings are instantly written to the device.

Check the Serial ID number before each write or burn
This option is useful for determining if the device connected to the programming box has changed since communication was first initialized with the device. If the software detects that the serial ID has changed, an error is displayed and you are required to re-initialize communication with the newly connected device.

Advanced PARAGON options
The options in this section apply only to PARAGON® products:

- In addition to bypassing the algorithm, put the device into low gain mode during communications: Puts the device into low gain mode during communication
- Bypass the algorithm during read operations: Bypass Mode is enabled during communication with the hybrid so that the signal is not distorted or modified in the wrong way during the download of new parameters. This reduces the communication noise that can be heard during telecoil mode.
Advanced Foundation/Rhythm options

The options in this section apply to products that support digital trimmers. These checks are used to ensure that the connected trimmers are functioning properly.

- Place trimmers at \( V_{REG} \) before configuration means position the wiper of the trimmer to \( V_{REG} \) before selecting Configure in the IDS.
- Place trimmers at GND before configuration (Recommended) means position the wiper of the trimmer to ground before selecting Configure in the IDS.
- Do not check trimmer connections is the alternative to the two trimmer check options above.
- Enable second level verification on trimmer connections checks that multiple queries of the trimmer setting return consistent results. If the trimmer is not consistent, an error message is displayed.

Use the I\(^2\)C communications protocol if it is supported by the programming box and device

When this option is selected, the software determines if the selected programming box and connected device support I\(^2\)C communication. If the software determines that the I\(^2\)C protocol is supported, the software sends commands to the connected device using the I\(^2\)C protocol. If the software determines that either the selected programming box or the connected device do not support the I\(^2\)C protocol, the software sends commands to the device using the SDA protocol. For the list of supported programming boxes and protocols supported for each, refer to Section 4.3, “Supported Interfaces and Protocols” on page 9.

![Options for the IDS Tools](image)

Figure 4: Options for the IDS Tools

5.3.2 Open Programmer

Opening the programming box (HI-PRO, DSP Programmer, etc.) in the IDS is the first step in initiating communication with a connected ON Semiconductor preconfigured DSP. Before selecting the Programmer > Open menu option, refer to Section 4.2, “Before Connecting” on page 9.
Programmer > Open in the IDS opens the connection to the programming box that is selected under Tools > Options.

5.3.3 Detecting Connected Chip (WhichChip)

Programmer > WhichChip in the IDS queries the device to determine the connected controller chip. The top-right corner in the IDS displays the Controller name of the connected device, as shown in Figure 5.

![Figure 5: Where the Controller’s Name is Displayed](image)

Figure 5: Where the Controller’s Name is Displayed

If you selected Use the **I**²**C** communications protocol if it is supported by the programming box and device, the software determines if the programming box and connected device support the I²C protocol, and then configures the device to operate in I²C mode.

5.3.4 Initializing a Device

When selecting Programmer > Init in the IDS, the software performs several initialization steps to prepare for further communications.

The IDS first attempts to determine if the selected product library is compatible with the connected device. If the selected product library does not match the library burned to the device, but the product types are compatible (e.g., the connected device is a Rhythm SB3229 and the selected product library is also Rhythm SB3229), a message box appears asking you how to proceed. Your options are:
**Burn Current**
Burns in the configurations for each memory from the selected product component.

**Read All**
Forces the IDS to switch to the product library that the device was last configured with and then read the configuration settings for each memory from the device.

**Cancel**
Cancels the initialization process and allow you to change the selected library manually.

*Note:* If the product that the device was last burned with is not registered on the computer, you only see the options **Burn Current** and **Cancel**.

The next step in initialization is to read in the control memory. The control memory contains the parameters that are displayed on the **Settings** tab. The control memory also contains information about calibration values and information required for proper modeling of the device in the IDS.

In the **Programmer** menu, choosing the **Open, WhichChip, Init** option performs Open, WhichChip and Init in one step.

### 5.3.5 Timing of the Connected Device

To return the timing of the connected device within the IDS, you can select **Programmer >Timing**. The programming box synchronizes itself to the device by measuring the device's sync time (the time between successive sync pulses). The value that is returned is a measure of the sync time. This feature is not available when using the **I2C** protocol to communicate.

### 5.3.6 Reading Settings from Connected Device

The two ways to read settings from a device in the IDS are:

- **Memory-Specific Read**: Use this type of read to read the parameters for the selected memory. To perform this type of a read, use the **Read** button located on the right-hand side of the memory tab you would like to read.
- **Read All**: Selecting the **Programmer > Read All** menu item in the IDS reads all the memories from the selected product component to the device including the parameters on the **Settings** tab.

### 5.3.7 Burning and Writing Settings to Connected Device

Burning parameters to a device refers to the process of taking the parameters selected in the IDS and storing them in the EEPROM of the connected device. When parameters are burned to a device the changes are permanent. Alternatively, writing parameters to a device updates the parameter settings in RAM only. These settings are lost when the device is power-cycled or you change memories using one of the memory tabs in the IDS or the memory select button on the device. You cannot write parameters on the **Settings** tab. These types of parameters can only be burned to the device.

Similar to a Read, two options are available for burning parameters to the device:

- **Memory-Specific Burn**: Using the **Burn** button on either the memory tabs or the **Settings** tab burns the selected memories parameters only.
• Burn All: Selecting the Programmer > Burn All menu item in the IDS burns all memories from the selected product component to the device including the parameters on the Settings tab.

5.3.8 Closing the Programming Box

Selecting the Programmer > Close menu item in the IDS closes the connection to the selected programming box. You must explicitly close the programming box before attempting to open the programming box again from another application.

5.4 ARK COMPONENT MANAGER

The ARK Component Manager (shown in Figure 6) is used to register product component libraries (DLLs) downloaded from ARKonline to be used with ARK and SOUNDFIT software. To access this tool, choose the Tools > ARK Component Manager menu item in the IDS. This tool can also be accessed through the Windows Start menu under ON Semiconductor > ARK > Configuration Tools > ARK Component Manager.

For more information about working with product component libraries in ARKonline, see Section 10.3.3, “Building a Library” on page 87.

![Figure 6: ARK Component Manager](image)

5.4.1 Viewing Installed Libraries

To view the list of installed product libraries or controller components, expand the tree menu item. Clicking on one of the installed libraries displays the Path to selected item. The path is abbreviated if it is too long for the dialog box; move the mouse over the path to display the full path.

5.4.2 Selecting a Library to Install

After you have created your library using ARKonline and downloaded the DLL you are ready to install the library. If you are just learning about installing libraries, you can use one of the demonstration libraries that are installed with ARKbase.

1. Click the Select file to install... button located in the bottom right-hand corner of the ARK Component Manager. A dialog box showing the folders on your workstation appears.
2. Browse through the folders and select the DLL that you would like to install.
3. Click **Open** and the library will be installed.

The library that you just installed appears under the **Product Component Libraries** tree menu. If you have trouble recognizing the library name, look at the path for the name of the DLL you just selected.

When returning to the IDS, the product component library that you just registered will appear in the Library drop-down box.

### 5.4.3 Deleting Installed Libraries

If you want to remove any of the Product Component Libraries installed on your workstation, you can remove them using the ARK Component Manager:

1. Select the library that you would like to uninstall by navigating through the **Product Component Libraries** tree menu.
2. Click **Uninstall**.

Choosing the option to **Delete DLLs when they are uninstalled** uninstalls the library and deletes the associated DLL from your computer. Only select this option if you will not need access to this product library in the future.

### 5.5 iLog

The iLog™ datalogging feature allows valuable information to be recorded in the hearing aid on a continual basis. This information can include, for example, the habits of the hearing aid wearer, the types of environments they spend their time in, and information about the hearing aid itself. iLog datalogging is designed to record data during the time between visits to the audiologist. Audiologists can use this information when fitting hearing aids for patients.

If iLog datalogging is enabled on a hearing aid, iLog parameters are continually recorded when the hearing aid is turned on. Once these parameter values are read from the device, they can be used to counsel the patient and fine-tune the fitting. Information about the state of the hearing aid and its environment are recorded to non-volatile memory at set intervals. The feature can be enabled with the IDS, and information collection begins the next time the hybrid is powered up. This information can be downloaded for analysis.

#### 5.5.1 Interfacing with the Device

This section assumes that you have established communication with a connected device (**Programmer > Open, WhichChip, Init** menu item). See Section 5.3, “Communication” on page 14 for more information.

#### 5.5.1.1 Reading and Clearing the Datalog

In the IDS, selecting **Tools > Read Data Log** causes:

1. A prompt for the number of iLog pages to read
2. The iLog data log to be read
3. A CSV file to be created with the read data
4. The iLog application to be launched and loaded with the CSV file
Selecting the Tools > Clear Data Log menu item causes the iLog data log to be cleared, including both the short-term circular buffer and the long-term counters.

5.5.1.2 Enabling and Setting iLog Parameters

To enable datalogging, do the following from the IDS window:

1. Select the Settings tab.
2. Change the DataloggingEnable parameter to enabled.
3. If you want to record the ambient sound level:
   • Change the LogAmbientLevel parameter to enabled.
   • Set the AmbientThreshold parameter to the threshold required to stimulate a new iLog entry. This manufacturer or audiologist specifies this threshold.
4. Set the interval of the datalogging by choosing a value for the LogInterval parameter, described in Section 5.5.4.1.3, “Long-Term Data” on page 26.
5. Click the Burn button.

These settings will only take effect once they have been burned in and the part is rebooted.

5.5.2 iLog Application

In the iLog application, the data is displayed graphically in such a way that it can be used by the audiologist to counsel the patient and fine-tune the fitting. To incorporate this iLog Application into other applications, launch the iLog executable (ensuring that you pass the name of the CSV file as an argument) from the calling application.

Alternatively, you can launch the iLog application from the IDS with the Tools > Read Data menu option, after you have connected to the device (see Section 5.5.1, “Interfacing with the Device” on page 19 for details).

Figure 7 shows an example of the iLog Application.

**IMPORTANT:** The time scale of these graphs only represents the time when that memory was being used, not the entire time the hearing aid was on.
The available tabs are:

**Memory Select**
- Shows the Memory Select statistics—what percentage of time the hearing aid has been in each memory. This data is retrieved from the long-term data logs. The Memory [A,B,C,D,E,F] tabs show the volume control level and ambient sound level measurements for each memory when that particular memory was in use. This short-term data logs provide the data.

**All Memories**
- Shows a combination of parameters so that they can be compared to each other. It shows the iSceneDetect Mode, Selected Memory, Ambient Level, and Volume Control, all on the same time scale. The time scale represents the entire time the hearing aid was on. For all the X-Y graphs, view the measurements in more detail:
  - To zoom in on the time scale (x-axis), click on the graph and drag horizontally, selecting the time you want to zoom in on.
  - To zoom out, right-click on the graph and select **Un-Zoom**.
  - You can right-click at any time and select **Show Sessions** to display vertical lines indicating the points at which memory switches occurred.

**Environment**
- Shows a pie chart that displays iSceneDetect™ statistics—what percentage of the time the hearing aid was in each iSceneDetect mode or whether iSceneDetect was off. The **Battery Level** tab shows the measured battery levels the entire time the hearing aid was on.

**Battery Level**
- Shows the history of the battery power. The resolution is higher (i.e., the measurement increments will be smaller) for iLog versions greater than iLog 1.0 because they contain more battery level intervals.
The iLog viewer has the ability to save the current iLog datalogs using the **Save to File** button. A previously stored datalog can be loaded using the **Load from File** button. The iLog application can be customized to display different colors for the data on various pie charts and graphs. The `config.xml` file that is located in the same directory as the IDS can be modified to add the RGB values of the desired colors that the user wishes to have displayed. The `config.xml` file must be stored in the same directory as `iLog.exe`.

### 5.5.3 iLog Datalogging Methods

The datalogging information is recorded using two methods in parallel: a short-term method and a long-term method. The short-term method is used to record detailed information about the patient’s hearing aid settings and environment (i.e., memory changes, volume control (VC) settings, battery levels, etc.). The long-term method is used to record how much time was spent in each memory over the life of the hearing aid (or since the last time the log was cleared).

#### 5.5.3.1 Short-Term Method

In the short-term datalogging method, data is recorded in a circular buffer. The parameters being logged are immediately recorded at device power up and checked thereafter at regular time intervals. In iLog 1.0, this interval is 15 minutes long. In later versions of iLog, the interval is set by the hearing aid manufacturer or audiologist, and can be anywhere from 4 seconds to 60 minutes. Adjusting the datalogging interval can extend the life of the buffer before it starts to get overwritten with new data. This feature could be particularly useful for a first time hearing aid wearer who might make a lot of adjustments in the first few days of wearing a hearing aid.

When the parameters are checked, data is only recorded if one of the following occurs to save space in memory for more useful log information:

- A parameter value changes.
- The timestamp value is at its maximum (63 in the case of iLog 1.0 and 255 in later versions) and is about to wrap around to 1. Parameters must be recorded when the timestamp value is about to wrap around to properly calculate the actual time that the hearing aid has been on.
- The ambient sound level parameter is enabled, and the level change exceeds the threshold associated with it.

The sizes of the circular buffer are:

- 183 entries (for iLog 1.0)
- 750 entries (for iLog 2.0 and greater)

The parameters recorded using the short-term method are as follows:

- Program Memory Selection
- Volume Control Setting
- Ambient Sound Level
- Battery Level
- iSceneDetect Settings

#### 5.5.3.2 Long-Term Method

The long-term datalogging method uses a counter for each memory which is updated at device power up and at regular intervals. The counters are updated at the same time interval as that of the short-term method, except that they are always updated no matter whether there has been a change or not. When the counters are updated, the counter that corresponds to the hearing aid’s
current memory is incremented by one. The number of counters available corresponds to the number of memories supported by the connected device.

Based on the value stored in the counters, the following information can be calculated:

- Length of time the hearing aid has spent in each memory (since data log was last cleared)
- Total length of time the hearing aid has been powered on (since data log was last cleared)

Note: All circular buffer entries and counters are protected using checksum verification.

### 5.5.4 CSV Files

The iLog data can be displayed using the iLog Application (included with ARKbase). The iLog Application needs a CSV (Comma Separated Values) file containing the iLog data to display. This CSV file can be constructed by the fitting software and has the format described below. The iLog Application needs the name of the CSV file passed to it as an argument when it is started. Once open, the iLog Application can open other, previously created CSV files.

#### 5.5.4.1 CSV File Format

The CSV file contains all of the iLog data recorded in the device. Because iLog only records data at startup, when parameters have changed, and when the timestamp value is about to wrap around, these are the only entries that appear in the CSV file.

The CSV file has the following sections:

- Version line
- Short-term data
- Long-term data

##### 5.5.4.1.1 Version Line

The version line is the first line of the CSV file. For example, for iLog 5.0, this line is:

```
--Version 5.0--
```

##### 5.5.4.1.2 Short-Term Data

The short-term data appears in consecutive lines, each line corresponding to a data log entry for a particular point in time. Each line consists of the following values depending on the product selected, in the order given, separated by commas:

1. Timestamp
2. Battery Level
3. Memory
4. Volume Control Level
5. Ambient Sound Level
6. iSceneDetect Value (Environmental Code)

Because log entries are only made when recorded parameters have changed, you can assume that the values between the log entries (during the time of the missing time stamps) are the same as the earlier log entry.
The details of the values on each line are described below.

**Timestamp**

The timestamps for version iLog 1.0 and iLog 2.0 and later versions are different, as described below:

**iLog 1.0**

The timestamp value is an integer from 0 to 63. In iLog 1.0, the interval between two consecutive numbers (i.e., from 0 to 1), is always 15 minutes. At power on, the datalogging routine always logs a new entry with a timestamp of 0 to represent a new session. If any of the parameters being tracked are found to have changed since the last time they were checked, a new entry is created with a timestamp representing the number of time intervals since the timestamp value was reset or the hybrid was powered on. If the device’s timestamp reaches 63, a log entry is created with the timestamp of 63 and the next timestamp increment will be 1. The timestamp is not 0, as might be expected, because a timestamp of 0 always represents the device being powered up.

**iLog 2.0 and greater**

The timestamp value is an integer from 0 to 255. Each increment of the timestamp represents a time interval. This interval is set by the hearing aid manufacturer or the audiologist, and can be anywhere from 4 seconds to 60 minutes.

At power on, the datalogging routine always logs a new entry with a timestamp of 0 to represent a new session. If any of the parameters being tracked are found to have changed since the last time they were checked, a new entry is created with a timestamp representing the number of time intervals since the timestamp value was reset or the hybrid was powered on. If the device’s timestamp reaches 255, a log entry is created with the timestamp of 255 and the next timestamp increment will be 1. The timestamp is not 0, as might be expected, because a timestamp of 0 always represents the device being powered up.

**Battery Level**

The battery level resolution is lower in iLog 1.0 than in iLog 2.0 and more recent versions. The differences are explained below.

**iLog 1.0**

The battery level is an integer value from 0 to 3 with the value corresponding to the ranges in Table 2.

**Table 2: iLog 1.0 Battery Levels**

<table>
<thead>
<tr>
<th>Value</th>
<th>Range (volts)</th>
</tr>
</thead>
<tbody>
<tr>
<td>3</td>
<td>1.3 or higher</td>
</tr>
<tr>
<td>2</td>
<td>1.2 - 1.29</td>
</tr>
<tr>
<td>1</td>
<td>1.1 - 1.19</td>
</tr>
<tr>
<td>0</td>
<td>Less than 1.1</td>
</tr>
</tbody>
</table>
iLog 2.0 and greater

The battery level is an integer value from 0 to 15 (decimal) with the value corresponding to the ranges in Table 3.

**TABLE 3: ILOG 2.0 AND GREATER BATTERY LEVELS**

<table>
<thead>
<tr>
<th>Value</th>
<th>Range (volts)</th>
</tr>
</thead>
<tbody>
<tr>
<td>15</td>
<td>1.468 - 1.502</td>
</tr>
<tr>
<td>14</td>
<td>1.444 - 1.467</td>
</tr>
<tr>
<td>13</td>
<td>1.421 - 1.443</td>
</tr>
<tr>
<td>12</td>
<td>1.397 - 1.420</td>
</tr>
<tr>
<td>11</td>
<td>1.373 - 1.396</td>
</tr>
<tr>
<td>10</td>
<td>1.350 - 1.372</td>
</tr>
<tr>
<td>9</td>
<td>1.326 - 1.349</td>
</tr>
<tr>
<td>8</td>
<td>1.303 - 1.325</td>
</tr>
<tr>
<td>7</td>
<td>1.279 - 1.302</td>
</tr>
<tr>
<td>6</td>
<td>1.256 - 1.278</td>
</tr>
<tr>
<td>5</td>
<td>1.232 - 1.255</td>
</tr>
<tr>
<td>4</td>
<td>1.208 - 1.231</td>
</tr>
<tr>
<td>3</td>
<td>1.185 - 1.207</td>
</tr>
<tr>
<td>2</td>
<td>1.156 - 1.184</td>
</tr>
<tr>
<td>1</td>
<td>1.135 - 1.155</td>
</tr>
<tr>
<td>0</td>
<td>Less than 1.135</td>
</tr>
</tbody>
</table>

For all versions of iLog, datalogging ceases if the battery level drops below 1.13V. This restriction prevents memory corruption on the EEPROM. Burning datalog values to memory with low or unstable voltage levels is not safe. Datalogging starts again once the patient has replaced the battery.

**Memory**

The Memory value can be an integer value from 0 to 5:

- 5 = Memory F
- 4 = Memory E
- 3 = Memory D
- 2 = Memory C
- 1 = Memory B
- 0 = Memory A

**Volume Control Level**

The Volume Control level is a decimal number (with one decimal place) with a value from 0 to -47.1dB, where the value corresponds to the actual volume control level.
Ambient Sound Level

The Ambient Sound Level is an integer with a value from 55 to 100dB SPL. The value corresponds to the actual ambient sound level.

iSceneDetect Value

The iSceneDetect value is an integer from 0 to 14 (decimal), with the value corresponding to the environmental modes below:

- 0 = Quiet Mode
- 2 = Speech in Quiet Mode
- 4 = Music Mode
- 8 = Noise Mode
- 10 = Speech in Noise Mode
- 14 = Off
- Odd value = Wind Mode (i.e., 1, 3, 5, 7, 9, 11, 13)

5.5.4.1.3 Long-Term Data

The long-term section of the CSV file consists of two lines for iLog 2.0 and greater, and one line for iLog 1.0.

The first line consists of integer numbers separated by commas. (The number of values in this line corresponds to the number of memories supported by the connected device.) These numbers represent the values in the long-term counters. They are integers between 0 and 1048575.

The last line of the CSV file in iLog 2.0 and greater is a number indicating the time interval between iLog checks. This is the number that was programmed into the device. The time (in seconds) can be calculated from this number using the formula:

\[ \text{Interval Time (in seconds)} = (X + 1) \cdot 4.096 \]

where \( X \) is the number in the CSV file; see Table 4 for a list of possible numbers.

The Log interval value read from the product is an integer in the range of 0 to 11. To convert from this integer to the values that are written in the CSV file, and to see the corresponding interval time, use the conversion table in Table 4.

**Table 4: Conversion Table for Interval Times**

<table>
<thead>
<tr>
<th>Values Read from Device</th>
<th>CSV File Values</th>
<th>Interval Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
<td>4s</td>
</tr>
<tr>
<td>1</td>
<td>2</td>
<td>12s</td>
</tr>
<tr>
<td>2</td>
<td>6</td>
<td>30s</td>
</tr>
<tr>
<td>3</td>
<td>14</td>
<td>1min</td>
</tr>
<tr>
<td>4</td>
<td>28</td>
<td>2min</td>
</tr>
<tr>
<td>5</td>
<td>72</td>
<td>5min</td>
</tr>
<tr>
<td>6</td>
<td>146</td>
<td>10min</td>
</tr>
</tbody>
</table>
### 5.5.4.2 iLog CSV File Example

The following snippet is an example of the text that appears in a typical CSV file:

```plaintext
--Version 5.0--
0,15,1,-25.9,55,14
51,15,2,-8.5,55,14
52,15,0,-1.2,55,2,
53,15,1,-1.2,55,14
255,15,0,-1.2,55,2
4,15,0,-1.2,55,2
5,15,1,-1.2,55,14
6,15,1,-38.6,61,14
7,15,1,-1.2,76,14
9,14,2,-1.2,67,14
0,14,3,-5,55,14
11,14,3,-11,55,14
12,14,0,-1.8,55,4
255,14,3,-11,55,14
0,9,2,-11,55,14
2,9,0,-11,55,2
5558,4462,270,376,343,235
219
```

It can be seen from the snippet of the file that:

- The device was started three times as shown by the three lines that begin with 0.
- The last line has the interval value: 219. Using the formula in Section 5.5.4.1.3, “Long-Term Data” on page 26, the interval time is \((219 + 1)*4.096 = 901.12\) seconds = 15.02 minutes = ~15 minutes
- At the first startup (the second line of the snippet), the numbers are interpreted as explained in Table 5.

### TABLE 4: CONVERSION TABLE FOR INTERVAL TIMES (CONTINUED)

<table>
<thead>
<tr>
<th>Values Read from Device</th>
<th>CSV File Values</th>
<th>Interval Time</th>
</tr>
</thead>
<tbody>
<tr>
<td>7</td>
<td>219</td>
<td>15min</td>
</tr>
<tr>
<td>8</td>
<td>292</td>
<td>20min</td>
</tr>
<tr>
<td>9</td>
<td>438</td>
<td>30min</td>
</tr>
<tr>
<td>10</td>
<td>658</td>
<td>45min</td>
</tr>
<tr>
<td>11</td>
<td>878</td>
<td>60min</td>
</tr>
</tbody>
</table>

### TABLE 5: INTERPRETATION OF A LINE IN A SAMPLE iLOG CSV File

<table>
<thead>
<tr>
<th>CSV File Data</th>
<th>Interpretation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Device starts</td>
</tr>
<tr>
<td>15</td>
<td>The battery level is between 1.47V and 1.5V.</td>
</tr>
<tr>
<td>1</td>
<td>The device is using memory B.</td>
</tr>
</tbody>
</table>
The second line shows that after 765 minutes (51*15 because the interval is set to 15 minutes), or 12 hours and 45 minutes, the memory was changed to C (third number) and the Volume Control Level was changed to -8.5 dB (fourth number). All the other parameters stayed the same. We can infer that between Time 0 and Time 12 hours and 45 minutes, all the parameters stayed the same as they were at Time 0.

### 5.6 Evoke Feature

Evoke is a feature on select ON Semiconductor preconfigured products that plays alerting acoustic indicators that are richer and more meaningful than simple tones played out consecutively. These acoustic indicators play whenever one of the predefined events occurs on the device.

#### 5.6.1 Evoke Editors

There are two types of Evoke editors available within the IDS: Evoke and EVOKE Lite™. Evoke Lite is a simpler version of Evoke. Both editors allow for customization of tones for a set of predefined system events. The sections below outline the capabilities of Evoke and note when the feature is not supported in the Evoke Lite Editor.

Once your computer is connected to a device that supports Evoke, you can launch the Evoke Editor by selecting the **Tools > Evoke Editor** or **Tools > Evoke Lite** menu item. See Figure 8 for an example of the Evoke editor window, and see Figure 9 for an example of the Evoke Lite editor window.

![Evoke Editor](Figure 8: Evoke Editor)

#### TABLE 5: INTERPRETATION OF A LINE IN A SAMPLE iLOG CSV FILE (CONTINUED)

<table>
<thead>
<tr>
<th>CSV File Data</th>
<th>Interpretation</th>
</tr>
</thead>
<tbody>
<tr>
<td>-25.9</td>
<td>The Volume Control Level is -25.9dB.</td>
</tr>
<tr>
<td>55</td>
<td>The Ambient Sound Level is 55dBSPL.</td>
</tr>
<tr>
<td>14</td>
<td>iSceneDetect is in Off Mode.</td>
</tr>
</tbody>
</table>

![Image]
5.6.1.1 Reading the Acoustic Indicators from the Device

Selecting an acoustic indicator from the drop-down list allows you to choose which available acoustic indicator to view or edit. The Read Indicator button reads the selected indicator from the connected hearing aid, and fills the table of tone values with the read information. The Read All Indicators button reads all the indicators from the hearing aid and loads the information for each indicator. After performing this step, selecting any indicator from the list displays the indicator data that is stored in the part.

5.6.1.2 Creating Acoustic Indicators

Rich and sophisticated sounds can be created using the Evoke Editor. Two types of tones can be created: Faded Simple Tones that have fade-in and fade-out transitions (similar to legacy pure tones from older products), or Damped Tones that decay with time in an exponential matter. An acoustic indicator of up to four faded tones can be created by selecting the Faded Simple Tones checkbox. Otherwise, the acoustic indicator is created with up to six damped tones. The amplitude of a damped tone will decay to 37% of its original value after the time specified in the Decay column has elapsed.

Note: The Evoke Lite Editor only supports faded simple tones. There is no Decay setting available for faded simple tones. The No Decay setting does exhibit a very small decay with time. The Decay column is disabled in the Evoke Editor when Faded Simple Tones are enabled.

All enabled tones are played in the user-selected sequence to produce a sound. In the Evoke Editor, you can define the rhythm and duration of the tones. To control the start and end times of a tone, select a suitable value from the Start Time and End Time columns. These values represent the time that the tone will either start or end. The total length of the acoustic indicator is controlled by selections from the Total Indicator Duration drop-down list. It is important to note that end times must always be greater than start times for all enabled tones. In addition, we suggest that the total indicator duration always be greater than the largest end time for any enabled tone in the sequence to ensure that all enabled tones are played to completion. The software will warn you if this is not the case.

In Evoke Lite, you only have control over the duration of each tone and the silence duration to follow the tone.
The volume of the tone is controlled using the Amplitude column. In Evoke, this feature allows certain tones in the sequence to be louder or softer than others. Also, this setting controls the overall volume of the indicator. To increase or decrease the volume of the indicator, adjust the amplitudes of all the enabled tones accordingly. To avoid tone distortion, do not use high amplitude settings (i.e., greater than -6 dB) when selecting a frequency greater than 4000 Hz, or when two tones are to be played out simultaneously. Evoke Lite supports only a single amplitude for all tones.

The frequencies of the tones used to create an Evoke acoustic indicator can be controlled by selecting a desired frequency from the Frequency column. All the frequencies listed are in Hz. All individual tones are pure tones with a frequency equal to the selected frequency in the drop-down list.

Note: The available frequencies in the IDS are notes from the musical scale. Some legacy frequencies at the upper range of the frequency spectrum are also included in the list.

5.6.1.3 Example Indicators

The Evoke and Evoke Lite Editors come packaged with a selection of acoustic indicator examples. Selecting an example indicator from the Example Indicators drop-down list loads the settings from the example indicator into the table of tone values for the selected acoustic indicator index. From this point, you can edit the acoustic indicator and burn it into a device.

5.6.1.4 Burning Indicators

Once you have finished creating a given indicator, you can play it on the device to see what it sounds like. The acoustic indicator can only be played on the hearing aid. As such, the indicator must be burned into the device first. Burning an acoustic indicator overwrites the acoustic indicator that was previously in the device. If you want to maintain the existing indicator in the device, ensure that it was saved to an Evoke file (see Section 5.6.1.5, “Loading and Saving Indicators” on page 30) prior to playing or burning the new indicator. The following buttons initiate burning:

Burn and Play Indicators
Burns the selected acoustic indicator into the device and plays it.

Burn Indicator
Burns the indicator but does not play it.

Burn All Indicators
Burns all the indicators into the device.

5.6.1.5 Loading and Saving Indicators

To save or load a set of Evoke acoustic indicators, choose one of the following from the File menu:

Save Indicators to File
Save the acoustic indicators for later use to an XML file (*.xml).

Save Indicators to File As
Save the acoustic indicators for later use to a new XML file (*.xml).
Load Indicators from File
   Load a set of acoustic indicators from a previously saved file.

The indicators are also saved when an IDS file is saved. An IDS file (*.ids) is the file where the Interactive Data Sheet saves its settings for use in CalConfig. When an IDS file is saved, all of the data from the Evoke Editor is saved as well. Conversely, when an IDS file is loaded, all of the acoustic indicator data is loaded into the Evoke Editor, and can be seen when the Evoke Editor is launched.

5.7 TRIMMER CONFIGURATION

The IDS enables users to configure the trimmers for their devices. Interfaces for trimmer selection and reading back trimmer assignments and levels is available within the IDS.

5.7.1 Assigning Trimmers

There are three product families that support trimmer configuration: FOUNDATION®, CONSOLIDATOR™ and Rhythm. Foundation and Consolidator assign trimmers in the same way. The newer Rhythm family of trimmer-based products supports further trimmer capabilities and therefore has a different interface for assigning trimmers. Both methods are described below.

For Foundation and Consolidator products, the trimmer assignments are completed on the Field Adj tab. Below each parameter that can be assigned to a trimmer is a drop-down box with the options None, 1, 2, 3, and 4. This defines which trimmer the parameter will be assigned to. Once the trimmer assignments are completed, you can switch to the Trimmers tab which displays a control that can be dragged in a circular motion to emulate the effects of the trimmer. The graphs will be updated to show how each value affects the frequency response of the device.

For Foundation and Consolidator product libraries created using ARKonline, only parameters that have been selected as being field-adjustable will appear on the Field Adj tab. Refer to Section 10.4.3, “Editing a Map” on page 91 for further information on editing the parameters.

For Rhythm trimmer-based products, the trimmer assignments are completed using a different dialog box that can be access from the Trimmers > Assign Trimmers menu item. The Trimmer Assignments dialog box (see Figure 11) allows you to save up to eight trimmer configurations for each product, and then select the trimmer configuration to use at manufacturing time within CalConfig. The top of each trimmer configuration has:

---

Figure 10: Foundation Field Adj. Tab

For Rhythm trimmer-based products, the trimmer assignments are completed using a different dialog box that can be access from the Trimmers > Assign Trimmers menu item. The Trimmer Assignments dialog box (see Figure 11) allows you to save up to eight trimmer configurations for each product, and then select the trimmer configuration to use at manufacturing time within CalConfig. The top of each trimmer configuration has:
Trimmer Configuration Name

Enter a different name for each trimmer configuration in the text box. This name is displayed in a drop-down box within the CalConfig application when the associated IDS file is selected.

Use these Trimmer Assignments when Configuring using IDS

The checkbox allows you to test the different trimmer configurations within the IDS.

![Figure 11: Trimmer Assignments Dialog Box](image)

Within the Rhythm Trimmer Assignments dialog box, use the checkboxes to assign parameters to each trimmer number. You can also assign multiple parameters to a single trimmer, as appropriate. Once the trimmer assignments are completed, select the File > Save Settings and Exit menu item. This saves your trimmer assignments so that when you are ready to save your IDS file, these trimmer settings are saved with this configuration.

Depending on the chosen settings, the trimmers might not be compatible. During the save routine, the IDS verifies that the parameters that are assigned to the trimmers are compatible. If they are not, the IDS displays an error, and you must modify the trimmer assignments before saving.

### 5.7.2 Configuring Trimmers

The concept of configuring a device within the IDS applies to all digital trimmer-based products and Foundation programmable-based products only. For products where a configuration is required, there will be a Configure button on the IDS dialog box alongside the Read, Write and Burn buttons. Alternatively, selecting the Programmer > Configure menu item performs this functionality as well.
For a trimmer-based product, configuration will perform the following steps:

1. Burn the control memory (including Setting tab parameters) to the connected device.
2. Verify that the parameters assigned to trimmers have a maximum of 16 values in their lists and that multiple parameters assigned to the same trimmer have the same number of values in their lists.
3. Clear the trimmer assignments currently configured to the device.
4. Any parameters that are assigned to trimmers are re-set to their default values for configuration and burn these settings to the device.
5. If an acoustic indicator file has been selected, it will be burned.
6. The trimmer assignments will be checked to ensure that none of the settings would put the device into an invalid state.
7. Disable the man-machine interface (MMI). This prevents users from adjusting any of the trimmers, memory select or volume control buttons on the device during configuration of the trimmers.
8. Trimmer assignments are programmed to the device.
9. The MMI is re-enabled.
10. If this is a Foundation programmable mode product, the IDS switches from the configuration library to the field library.

### 5.7.3 Reading Trimmers

Within the IDS, you have the ability to read back the trimmer assignments and the levels of each of the trimmers. For Foundation and Consolidator, this feature is available when initializing a device that has already been configured. A message box appears giving you the option to Read Trimmers or Skip Read. The graphs in the IDS are updated to reflect the trimmer levels read from the device when selecting the Read Trimmers option.

For Rhythm products, the trimmer assignments can be read out using the Trimmers > Read Trimmer Assignments menu item. You can also turn the trimmers on the device and continually read out the values to see the levels changing. When reading the trimmer levels, the graphs in the IDS are updated to show the effects of the different trimmer settings on the frequency response of the connected device.

**Note:** For Rhythm products, when assigning an EQ value to a trimmer such as Centre, Q or Depth, as the trimmer value is read back, all three will appear to be trimmer-assigned.

### 5.8 CALCONFIG SETUP

When you have completed the design work and selected the final settings, select the calibration steps that you want to perform for the product by using the CalConfig > Setup menu item in the IDS. Refer to Section 9.4, “CalConfig and the IDS” on page 63 for a description of the calibration settings available.

### 5.9 SECURITY FEATURES

ON Semiconductor preconfigured DSP products supports several optional security features designed to protect hearing instrument manufacturers’ software and proprietary preconfigured products. This section describes each security feature, their purpose, use and implementation.
5.9.1 DLL Protection

**Purpose**

To prevent third parties from viewing or using a given manufacturer’s DLL.

**How To Use**

1. In the ARKonline library manager (see Chapter 10, “ARKonline” on page 83 for details), enter an alphanumeric password for the library once the library is created. The password can contain up to 16 characters. Only letters and numbers are allowed, not special characters.
   The password is case sensitive.
2. Select the **Enable DLL Protection** checkbox.
3. When you open the library for the first time in the IDS, it asks you for the library password. If you enter an invalid password, no products are loaded and the library is unusable. The IDS stores correct passwords in the Windows Registry so that a password is only required once per system.

**Fitting Software Use**

For fitting software, we suggest that manufacturers store the passwords for each library internally to the software. Thus, libraries can be loaded automatically.

For further information about implementing security features within fitting software, refer to the *Application Resource Kit Programmer’s Guide*.

5.9.2 Hybrid Authentication

**Purpose**

To prevent third parties from cloning a given manufacturer’s device EEPROM and trying to use the cloned device with that manufacturer’s fitting software.

**How To Use**

1. In the ARKonline library manager (see Chapter 10, “ARKonline” on page 83 for details), enable the **Hybrid Authentication** feature on the **System Features** page.
2. On the following page, enter an alphanumeric seed value. The seed value can contain up to 16 characters. Only letters and numbers are allowed, not special characters. The seed value is case sensitive. Once a library is built and in use, do not change the seed values.
3. Ensure that the **PartLocked** parameter is set to disabled at this point (located on **Settings** tab in the IDS). If PartLocked is set to enabled, Hybrid Authentication will be enabled in addition to DLL to Hybrid Pairing. (Refer to Section 5.9.3, “DLL to Hybrid Pairing” on page 35 for more information.)
4. During configuration of the device in CalConfig (or burning the control parameters on the **Settings** tab in the IDS), a special encrypted value is burned to the scratch area of the connected device.

**Fitting Software Use**

Immediately after calling **Init** in the fitting software, the key in the scratch space is compared to the key in the library. If these values do not match, an error message appears.
For further information about implementing security features within fitting software, refer to the Application Resource Kit Programmer's Guide.

5.9.3 DLL to Hybrid Pairing

Purpose

To prevent a given manufacturer's device from being upgraded from a product with limited features to a product with more features while out in the field.

How To Use

1. In the ARKonline library manager (see Chapter 10, “ARKonline” on page 83 for details), enable the Hybrid Authentication feature on the System Features page.
2. On the following page, enter an alphanumeric seed value. The seed value can contain up to 16 characters. Only letters and numbers are allowed, not special characters. The seed value is case sensitive. Once a library is built and in use, do not change the seed values.
3. During configuration of the device in CalConfig (or burning the control parameters on the Settings tab in the IDS), a special encrypted value is burned to the scratch area of the connected device.
4. Ensure that the PartLocked parameter is set to enabled at this point. It must be set to enabled in the IDS file before configuring the device in CalConfig.
5. To allow devices with this feature to be changed to different products in the field, set the seed values in the maps to be equivalent.

Fitting Software Use

For further information about implementing security features within fitting software refer to the Application Resource Kit Programmer's Guide.

Note: If the PartLocked parameter is enabled and burned in a device where the library has a given seed value, that library must be maintained with the current seed value. If the library is deleted or the seed value is changed, the locked device will no longer be configurable.
6.1 INTRODUCTION

Modeling of hearing aid transducers (microphones, receivers and telecoils) is helpful in predicting the performance of a hearing instrument. The ability to accurately calculate hearing instrument parameters such as acoustic gain, maximum output level, compression ratios, or shape of frequency response reduces the time required to design a hearing aid.

To assist in the modeling process, this chapter describes how to measure the responses of microphones and zero bias receivers. Models of these components can then be used with the ARKonline Library Manager.

Modeler software is included in the ARKbase distribution package.

6.2 REQUIRED EQUIPMENT

The test equipment required for the measurements is:

- Frye FONIX 6500 or 7000 Hearing Instrument Test System equipped with RS232 interface and ANSI 2009 options
- Anechoic test box
- HI-PRO programming box, or equivalent
- Hearing instrument using ON Semiconductor digital hybrid with a microphone, receiver, or telecoil to be characterized
- All necessary cables

Although FONIX’s sound chamber is adequate to do the measurement, ON Semiconductor recommends using an anechoic test chamber such as the Interacoustics TBS25, or the Interacoustics TBS50 (http://www.interacoustics.dk) or Bruel & Kjaer Type 4232 (http://www.bkhome.com). The recommended test chambers provide better low frequency sound isolation and alignment of the hearing aid with the loudspeaker.

6.3 SETUP

Once ARKbase is installed, you can start the Modeler by choosing the ON Semiconductor > ARK > Development Tools > Modeler menu item from the Windows Start menu.

After installing the software, you must run the Frye FONIX 6500/7000 Configuration Tool. See Section 9.3.2, “Frye Configuration Tool” on page 63 for more information.

Connect the test equipment as shown in Figure 12.
6.4 MICROPHONE MEASUREMENT

Measurement of a microphone's sensitivity versus frequency is required to create the microphone model. For information on placement of a microphone inside an anechoic chamber, sound field leveling, acoustical couplers, and connections, refer to ANSI S3.22 - 1996 American National Standard Specification of Hearing Aid Characteristics.

To measure the microphone's sensitivity, you do not have to connect a receiver. The microphone's sensitivity is measured by the connected ON Semiconductor digital hybrid, and that data is sent to the computer.

The following steps are required to measure the microphone's sensitivity versus frequency:

1. Level the sound field inside the anechoic chamber using the Frye FONIX 6500 or 7000. Refer to your Frye FONIX manual for information about leveling the sound box.
3. In the Modeler’s Transducer box, choose either Front Microphone or Rear Microphone. The default setting is Front Microphone (see Figure 13).
4. Choose Tools > Options to display the Modeler Options dialog box.
5. Choose stimulus and measurement devices. Frye FONIX 6500 is the default (see Figure 14 on page 40). Also select the left or right ear port.
6. Click Run to start measuring. A graph and table showing measured values is displayed in real time on the computer screen (see Figure 15 on page 41).
Figure 13: The Modeler Program
Figure 14: Modeler Option Box
Figure 15: Results of Front Microphone Measurement

Note: The current configuration of the ON Semiconductor digital hybrid is overwritten by the Modeler program but can be restored by power cycling the device.

Sensitivity is measured with 90dBSPL pure tones at the input to the microphone. The frequency of these tones increases from 100Hz to 8000Hz in 100Hz increments. The microphone’s sensitivity is measured in dBVrms/dBSPL.

Once the measurements are finished, you can copy the results to the clipboard and paste them in the ARKonline Library Manager, or save them to a local file. The file format is tab-delimited ASCII text. The results can also be saved to a .mlr (modeler) type file which allows you to view it in the Modeler.
6.5 Receiver Measurement

To measure a zero bias receiver's parameters, you must connect a microphone and a zero-bias receiver to the ON Semiconductor digital hybrid. Acoustic signals inside the anechoic chamber are converted by the microphone to electrical signals going into the ON Semiconductor digital hybrid. The digital hybrid compensates for the microphone's frequency response and drives the zero-bias receiver with a constant level electrical signal.

To model a zero bias receiver, measurements of the receiver's sensitivity and saturation levels are required. We recommend using a flat/broadband frequency response microphone to maximize the accuracy of these measurements.

To measure a zero bias receiver's sensitivity and saturation:

1. Level the sound field inside the anechoic chamber using the Frye FONIX 6500 or 7000. Refer to your Frye FONIX manual for information on how to level the sound box.
3. In the Modeler’s Transducer box, choose Receiver (see Figure 13 on page 39).
4. Choose Tools > Options to display the Modeler Options dialog box.
5. Choose stimulus and measurement devices. Frye FONIX 6500 is the default (see Figure 14 on page 40).
6. Click Run to start measuring. A graph and table showing measured values is displayed on the computer screen. Sensitivity measurements are done first, followed by the saturation measurements (see Figure 16).
The receiver’s sensitivity is measured with -30 dBVrms pure tones between 100 Hz and 8000 Hz in 100 Hz increments. The saturation level of the receiver is measured with -1 dBVrms tones of the same frequencies as in the sensitivity measurement. The receiver’s sensitivity is measured in dBSPL/dBVrms and the saturation level is measured in dBSPL.

Once the measurements are finished, you can copy the results to the clipboard and paste them in the ARKonline Library Manager, or save them to a local file. The file format is tab-delimited ASCII text. The results can also be saved to a .mlr (modeler) type file which allows for future viewing in the Modeler, if required.

### 6.6 Telecoil Measurement

Measurement of a telecoil’s sensitivity versus frequency is required to create a telecoil model. For information on the placement of a telecoil inside an anechoic chamber, sound field leveling, acoustical couplers, and connections, refer to ANSI S3.22 - 1996 American National Standards Specification of Hearing Aid Characteristics.

To measure the sensitivity of the telecoil, you do not have to connect a receiver. The sensitivity of the telecoil is measured by the ON Semiconductor digital hybrid and the data is sent to the computer.
The following steps are required to measure the telecoil’s sensitivity versus frequency:

2. In the Modeler’s Transducer box, choose Telecoil (see Figure 13 on page 39).
3. Choose Tools > Options to display the Modeler Options dialog box.
4. Choose stimulus and measurement devices. Frye FONIX 6500 is the default (see Figure 14 on page 40).
5. Click Run to start measuring. A graph and table showing measured values is displayed on the computer screen (see Figure 17).

Figure 17: Results of Telecoil Measurement

Sensitivity is measured at 31.5 mA/m pure tones at the input to the telecoil. The frequency of these tones increases from 100 Hz to 8000 Hz in 100 Hz increments. The telecoil’s sensitivity is measured in dBVrms/dBSPL.

Once the measurements are finished, you can save the results to a local file. The file format is tab- delimited ASCII text. The results can also be saved to a .mlr (modeler) type file which allows for future viewing in the Modeler, if required.
6.7 MODEL ACCURACY

When measuring the microphones and zero-bias receivers, remember that a typical broadband microphone's sensitivity has ±3 dB tolerance. The sensitivity of Ski Slope or Step microphones has ±4 dB tolerance. Also, the sensitivity of a passive telecoil has ±2 dB tolerance and an amplified telecoil has ±3 dB tolerance. A typical zero-bias receiver's sensitivity can vary by as much as ±3 dB.

To create a nominal model, the measurements should ideally be done using nominal transducers. However, when you do not know whether the measured transducer has nominal parameters, we recommend measuring several transducers of the same type, and taking an average, or choosing the most typical one.
This page left blank for printing purposes.
7.1 INTRODUCTION

Filter Designer Plus is a stand-alone program that converts analog to digital coefficients for use with biquad filters. Automated transfer of the coefficients to the Interactive Data Sheet is also available in this program. A graph is displayed to show the total effect of the filters. A parametric filter section is available with amplitude, Q and frequency adjustments for six different parametric filter types.

To access this program, choose ON Semiconductor > ARK > Development Tools > Filter Designer Plus from the Windows Start menu. A window similar to Figure 18 appears.

![Figure 18: Filter Designer Plus](image)

7.2 GENERATING COEFFICIENTS

There are multiple ways to generate coefficients using Filter Designer Plus. All methods require the follow setup:

1. Select the platform from the Platform drop-down box.
2. Use the **Biquad** drop-down box to specify the biquad that the coefficients will be applied to.
3. Select the sampling frequency of the product that the coefficients will be generated for.

The following sections describe the various methods available for generating coefficients using the Filter Designer Plus application.

### 7.2.1 Transfer Functions

In Filter Designer Plus, you can generate coefficients using either the first order transfer function (*1st Order s->z* tab), or second order transfer function (*2nd Order s->z* tab). Coefficients are entered in the *s*-domain format and then converted to *z*-domain coefficients by Filter Designer Plus.

### 7.2.2 Parametric Filters

Filter Designer Plus gives you the ability to generate coefficients using a parametric approach. On the **Parametric** tab (see Figure 18 on page 47) the following controls are provided:

- **Centre Frequency**  
  Allows you to shift the centre frequency of the designed filter.

- **Q (Bandwidth)**  
  Increasing the Q value narrows the bandwidth and decreasing the Q value results in a wider bandwidth.

- **Amplitude**  
  Adjusting this slider increases or decreases the amplitude of the filter.

- **Filter Type**  
  The available filter types are:
  - **EQ**—equalizer
  - **LP**—low-pass
  - **HP**—high-pass
  - **BP**—bandpass
  - **LF Shelf**—low-frequency shelf
  - **HF Shelf**—high-frequency shelf

By adjusting these parameters in Filter Designer Plus, you can see the resulting filter response in the displayed graph.

### 7.3 Viewing Generated Coefficients

While designing each of your filters, you can view the coefficients that are generated. To view the coefficients, select the **View > Biquad Coefficients** menu item. The coefficients displayed here are the values that will be transferred to the IDS.

### 7.4 Transferring Coefficients

Once you have created the filters that you need for your product, you can transfer these settings to the IDS and apply the coefficients to your product component library:

1. Click the **Open IDS** button. This launches the IDS application installed with ARKbase.
2. From the IDS, select the library and product that you will be transferring the coefficients to. The product library selected in IDS must have generic biquad coefficients enabled to transfer coefficients from the Filter Designer Plus application.
3. From Filter Designer Plus, click the Transfer Coeffs button. The coefficients for all filters that have been designed are transferred to the IDS.

Filter Designer Plus can also be configured to automatically transfer the filter coefficients to IDS after any of the generated coefficients has changed. Selecting the Automatically Transfer Coefficients checkbox enables this feature.

7.5 Filters Graph

The Filter Designer Plus graph shows the response for each of the biquads. A legend is available under the View > Legend menu item that explains the colors for each of the biquads for the selected product.

In addition to showing the individual response for each biquad, a curve shows the sum of all biquads.
8.1 INTRODUCTION

The Feedback (FB) Path Measurement Tool is a new capability included with ON Semiconductor digital amplifiers, beginning with the INSPIRIA™ SA3286. This tool uses the built-in features of the amplifier to measure the maximum stable gain (MSG) of a hearing aid in a straightforward way. Knowledge of MSG is useful during hearing aid design and fitting: it can be used to either limit the gain or to determine if feedback management strategies are required.

The FB Path Measurement Tool consists of embedded routines running inside the digital amplifier as well as software routines for controlling the measurement and extracting the measured feedback path information. To illustrate how these capabilities can be used to perform a feedback path measurement, a sample application is also provided. This sample application is written in Visual Basic 6 and is included as part of the ARK installation package. The source code provided for this sample application, available in ARKsdk, serves as an example of how the FB Measurement Tool can be used to obtain a feedback-path measurement.

This chapter describes the principles of operation for the FB Measurement Tool and provides step-by-step instructions for performing a measurement using the sample application.

8.2 MEASURING FEEDBACK PATHS

The Feedback Path Measurement Tool is a fully functional Visual Basic 6 application. It is intended to be used as an example to help software developers incorporate the feedback path measurement capability into their own software. The source code and executable module are included as part of the ARK installation packages (source code is distributed with the ARKsdk package and executables are included with ARKbase) for digital amplifiers that support this feature. In addition to the product library requirements above, the application requires the following:

- Four pre-filters set to generic biquads with programmable coefficients
- Four post-filters set to generic biquads with programmable coefficients
- Both 1 mic omni and Rear Only must be enabled in the library
- HRX must be enabled
- Memory A is the active memory
- Data in registers matches data programmed into EEPROM (can be ensured by restarting the device)

Note: These elements are included for simplicity in developing the sample application and need not be included in manufacturer’s software. Refer to Section 8.3, “Feedback Path Measurement Principles” on page 56 for a description of the minimum requirements. A product component that includes all these features is included as part of the demo libraries supporting feedback path measurements.
To start the Feedback Path Measurement Tool, choose ON Semiconductor > ARK > Development Tools > Feedback Path Tool from the Windows Start menu.

The following sections explain the use of the Feedback Path Tool sample application, which is illustrated in Figure 19.

**8.2.1 Connecting to the Device**

The first step in reading the FB Path is to connect to the device:

1. Select the appropriate Programmer, Library, Product, and Ear side.
2. Click the Connect button. An error message is displayed if an error occurs while attempting to connect to the device; otherwise, the Read FB Path button is enabled.

**8.2.2 Setting Feedback Path Measurement Parameters**

You can specify the following feedback path measurement parameters:

**FE Mode**

Allows you to select which FE Mode to use. The FE Modes 1 Mic Omni and Rear Only are the only valid modes for use with the Feedback Path Measurement Tool.

**Background Noise Threshold**

Set the maximum ambient noise level, above which the tool cannot execute. The ambient levels observed in all channels must be below this threshold before an FB Path measurement can be performed.
Wait Period

Allows you to control the time that the FB Path Measurement Tool waits for the FBC to settle. The appropriate wait period depends on the device and the expected ambient noise levels (see ). Determine appropriate wait times for your application through experimentation (see Section 8.2.3, “Feedback Path Measurement Routine” on page 53); we suggest starting with settling times in the range of 15 to 30 seconds.

FB AcouDelay

This slider controls the FB Canceller Acoustic Pre-Delay. It determines the time offset applied to the beginning of the FBC. In normal FBC operation, it is intended to compensate for the varying acoustic delays in different hearing instruments. Recommended pre-delay settings for different hearing aid styles are provided on the feedback canceller tab in the IDS.

8.2.3 Feedback Path Measurement Routine

When you click the Read FB Path button, the feedback measurement routine performs the following steps:

1. The hybrid is set up for the measurement by writing the following parameter modifications to the device.
   - The Post 3 biquad’s b0 coefficient is set to 0. All other biquads are turned off.
   - HRX is turned on.
   - FE Mode is set to 1 Mic Omni or Rear Only.
   - WDRC slow detectors are set to 4 ms attack time and 32 ms release time.

2. The background noise in each channel is read using the level detectors. The measured background noise must be below the Background Noise Threshold in each channel for the FB path measurement to proceed. You will have to use experimentation to determine an appropriate background noise threshold value for each particular style of hearing aid.

3. The program initiates noise generation: flat noise, set to Post VC (Noise + HA audio).
   Note: The generated noise RMS level for a 16 kHz bandwidth product is 3 dB higher than for an 8 kHz bandwidth product.

4. The noise level is raised in 6 dB increments until it is above the background noise level measured in each channel by a margin specified in the Required Level Delta row. The purpose of generating the noise at a level above the channel background noise level by a certain delta is to ensure that the noise stimulus is loud enough to make a good FB path measurement.
   Note: Some level of experimentation is needed to establish appropriate Required Level Delta settings so that the FB path measurements are accurate, while ensuring that the patient is not harmed or put through unnecessary discomfort in the process. Keep in mind that the required deltas do not have to be the same size. For example, a hearing aid might not have a very strong low frequency FB path; therefore little of the low frequency energy from the receiver reaches the microphone. In this case, it might be impossible to produce noise that registers much more than 5 to 10dB as measured by the low frequency level detectors.

5. The FB Canceller is turned on and the program waits for the time period specified in the Wait Period text box to pass. This gives the FB Canceller time to properly adapt and settle. For a given noise level and hearing aid model, you can establish, through experimentation, an
appropriate wait time for the FB Path measurement to properly settle. Although the amount of time required for the measurement to stabilize varies with SNR, wait periods in the order of 15 seconds or more typically provide acceptable results.

6. The FB path measurements are taken by reading the FB Canceller coefficients while the FB Canceller is operating. The program makes a call to the `ReadFBPathSafe` function to read the FB Path coefficients. To get a more accurate reading of the FB coefficients, the FB Path coefficients are read a number of times and the average of the readings is taken. The variance and standard deviation of the measurements are also calculated to get an idea of how much the readings vary from each other.

7. Generation of the noise is stopped. The device is then returned to its previous settings and the results (i.e., individual measurements, averages, variances, and standard deviations) are saved to a comma separated value (CSV) file.

We recommend that you review the data to determine if the measurements were stable at the time of recording (i.e., the FB Canceller had properly converged by the time the measurements were taken). For a given hearing aid model and generated noise level, a large variance and standard deviation might indicate that the FB Canceller had not properly converged at the time the measurements were taken. In this case, a greater Wait Period (e.g., 5, 10, 15, or 20 seconds) might be warranted to achieve more accurate and reliable results. On the other hand, a low variance and standard deviation indicate that you can reduce the Wait Period (and thus the fitting time) without necessarily sacrificing results. The coefficients in the CSV file are those of an impulse response, an example of which is depicted in the impulse response graph in Figure 20 on page 55. From this impulse response, you can calculate a frequency response by generating the FFT data and graphing the results (See Section 8.2.4, “Generating FFT Data and Graphing” on page 54).

For more details about incorporating the Feedback Path Measurement Tool into fitting software, refer to the Application Resource Kit Programmer’s Guide.

8.2.4 Generating FFT Data and Graphing

The Feedback Path Measurement Tool also has the ability to generate the fast Fourier Transform (FFT) and graph the frequency response. After performing the feedback path measurements on the connected device click the Generate FFT Data and Graph button. This opens a new dialog box displaying the FFT data, frequency response and impulse response generated from the feedback path measurements.

For an example, see Figure 20. The tool was used to measure the feedback path for an open-fit receiver in the ear (RITE) instrument. The Input frame at the top of the Feedback Path FFT Response dialog box displays the impulse response graph. For this measurement, the acoustic pre-delay was set to 12 so the measured data has been automatically appended with leading zeros by the FB Tool software. The Output frame in the middle of the dialog box displays the resulting frequency response graph. The graph plots frequency (Hz) vs level (dB). This curve was obtained by calculating the 512-point FFT of the data returned by the Feedback Path Measurement Tool.
Figure 20: Generated FFT and Graphs

The feedback-path frequency response curve shows the level of feedback observed at the microphone signal (point B in Figure 22 on page 57), relative to the hearing-aid output signal (point A in Figure 22 on page 57). For this device, the feedback response peaks at -17.6dB at a frequency of 6.8 kHz; therefore, you can apply up to 17.6dB of digital gain to this device before getting feedback. This is the maximum stable gain of the instrument.

You can also generate and view the FFT response for a previous measurement by clicking the Open Existing File button on the Feedback Path FFT Response dialog box.

**Note:** When opening .csv files that were generated using an older version of the Feedback Measurement Tool (version 3.4.0 or earlier), you must know the sampling frequency to select on the Feedback Path FFT Response dialog box. For newer versions of the Feedback Path Measurement Tool, the sampling frequency is saved to the .csv file and the appropriate sampling frequency is automatically selected when generating the FFT response.

You can view all four measurements that are performed when reading the Feedback Path data from the device, or display the average of all four readings. Select how you want to view the
measurements in the Fast Fourier Transform area of the window shown in Figure 20 on page 55. The data in the Impulse Response and Frequency Response text boxes change to reflect the selection of Reading 1 - 4 or the Average reading.

8.3 Feedback Path Measurement Principles

The Feedback Path Measurement Tool uses the adaptive feedback canceller (FBC) to identify the impulse response of the feedback path. A measurement is performed by generating a known stimulus signal from the output of the hearing aid and allowing the FBC to adapt to the feedback observed at the microphone.

Due to the acoustic nature of the measurement and the fact that it is obtained using an adaptive system, you must ensure that an accurate measurement is obtained. Several factors can affect the accuracy of measurements obtained using the Feedback Measurement Tool, including the following:

- Digital amplifier configuration
- Ambient noise in the room where the measurement is being performed
- Measurement settling time
- Transducer saturation

ON Semiconductor digital amplifiers provide several features that can be used to overcome these factors and maximize the accuracy of the measurement. These features are described in more detail below.

8.3.1 Amplifier Configuration

To understand the configuration parameters that affect FB path measurements, it is important to know how the FBC is connected within the amplifier. A simplified block diagram of a digital amplifier equipped with an FBC is shown in Figure 21. This diagram includes Head Room Extension (HRX™), compression section (WDRC), volume control (VC), post-AGC biquads (PB), DAC and H-bridge power amplifier (HB) and shows the internal connections for the FBC.

As shown in Figure 21, the FBC forms a closed loop around the WDRC and VC blocks. While it is operating, the feedback seen by the FBC is only affected by blocks outside this loop. The FB path identified by the FBC thus includes the expected elements: DAC and H-bridge amplifier, receiver, microphone and any acoustic path from receiver to microphone. As shown in the diagram, however, the measured feedback path also includes the HRX circuitry. This is important to note since the gain of the HRX block is different when it is enabled compared to when it is disabled. When HRX is off, the observed gain of the feedback path is 18dB higher than that observed with HRX on. While IDS software automatically handles this change in gain distribution, any user-developed software must correct it prior to predicting the MSG of the instrument.
To improve the accuracy of the feedback path measurement, mute the forward audio path through the hearing aid. This prevents the feedback signal from propagating around the loop more than once, and it reduces the impact of ambient noise on the measurement.

The best way to mute the audio path is to set the coefficients of a post-AGC biquad to zero. The signal-path location of post-biquads 3 and 4 is shown by the PB block in Figure 21 above. This ensures that the audio path is completely muted while still allowing the microphone signal to propagate to the WDRC block. As described below, level detectors within the WDRC block can then be used to assess ambient noise conditions and to assess the accuracy of the measurement. The sample application uses post biquad number 3 for this purpose.

Finally, a noise stimulus signal must be injected into the hearing aid output. This can be accomplished by using the built-in tinnitus-noise generation feature. For proper operation, the injection point must be after the point at which the audio path is muted, preferably after the volume control (post VC option). Additionally, you must select the option to add tinnitus noise to the audio signal; otherwise, the audio path blocks are disabled. The sample application illustrates the steps required to inject stimulus noise in this way.

Once these steps are taken, the audio path within the amplifier appears as illustrated in Figure 22.

Acoustic feedback must be measured using a live hearing-aid microphone. The microphone picks up both the real feedback signal plus any ambient noise that exists in the room at the time of the measurement. The presence of significant ambient noise can enter the FBC calculation and
corrupt the measured feedback path. For this reason, it is important for the measuring software to be aware of the level of ambient noise and to adjust the measurement procedure accordingly.

ON Semiconductor amplifiers allow user software to determine the ambient noise level by reading the instantaneous values of the built-in WDRC level detectors. The values read from the level detectors can be compared against an absolute threshold to determine if the ambient noise level is too high to ensure a proper measurement. In addition, by comparing level detector readings before and after activation of the stimulus noise, it is possible to identify the level of feedback in relation to the ambient noise. This can be used to provide a rough indication of measurement accuracy. The sample application provided by ON Semiconductor illustrates the use of the level detectors to measure ambient noise levels. This is described in more detail in Section 8.2, “Measuring Feedback Paths” on page 51.

8.3.3 Settling Time

Settling time is another important factor to consider in measurement accuracy. The FBC requires a certain amount of time to determine the feedback path, once the stimulus noise is started. The exact amount of time required is variable and depends on the nature of the feedback path and the strength of the feedback signal observed at the microphone, relative to ambient noise. In general, a feedback path with a narrow-band frequency response is identified faster than a broad-band one; similarly, a strong feedback signal allows faster measurements than a weak one.

For a given application, the best settling time must be determined through trial-and-error. Compare repeated measurements using different settling times to see if they are converging to the same data. Perform this comparison on the frequency-response data since low-frequency noise can disturb the impulse response but is of no consequence to predictions of feedback. Once a stable reading is obtained, verify the accuracy by checking that the measurement correctly predicts the frequency and gain at which feedback occurs in the instrument.

While the appropriate settling time for a given application must be determined through this type of experimentation, settling times in the range of 15 to 30 seconds are suggested as a starting point.

8.3.4 Transducer Saturation

Transducer saturation can also affect the measured feedback path. This can occur if the selected stimulus noise level is too high. When a transducer is saturating, the apparent feedback path appears to be lower in amplitude than it is under nominal conditions. This is most likely to occur near frequencies where feedback is strong. Unfortunately, the tool cannot detect if external saturation is occurring; however, saturation can be identified by reducing the stimulus level and re-measuring the feedback path. If saturation is occurring, the measured frequency response will be gradually reduced as the stimulus noise level is increased. This will be particularly acute near frequency response peaks. Such compression of the measurements for higher stimulus levels indicates a saturation problem.

If saturation is suspected, reduce the stimulus to a level that is within acceptable limits for the chosen transducers. Repeat measurements at reduced stimulus levels to ensure that the measured data is converging to the same frequency response.
8.4 UNDERSTANDING FEEDBACK PATH DATA

The data returned by the Feedback Measurement Tool is a representation of the impulse response, or time response, of the feedback path. Since the tool uses the FBC to determine the impulse response, the time duration of the impulse response is limited to 40 samples for the Inspiria SA3286 product, and 64 samples for products based on the WOLVERINE™ platform. The time window of the measurement can be offset, however, using the acoustic pre-delay parameter. The acoustic pre-delay determines the time offset at the beginning of the measured impulse response. If the acoustic pre-delay is set to a value other than zero, a corresponding number of zeros are prepended to the measured impulse response. For the Inspiria SA3286, the number of data points returned by the Tool is $40 + \text{AcousticPreDelay} - 1$. (The minimum pre-delay value for the Inspiria SA3286 is 1; therefore a value of 1 is subtracted from the total number of data points to account for this zero sample.) For Wolverine-based products, the number of data points returned is $64 + \text{AcousticPreDelay}$. A more complete picture of the total impulse response can be obtained by repeated measurements using different acoustic pre-delay settings and combining the resulting data.

On its own, the impulse response data is difficult to interpret and does not directly provide an indication of MSG. To determine MSG, convert the impulse response data into a frequency response. This is accomplished by calculating the Fourier Transform of the impulse response using an algorithm such as the Fast Fourier Transform (FFT). This functionality is provided as part of the Feedback Path Measurement Tool and further details can be found in Section 8.2.4, “Generating FFT Data and Graphing” on page 54.

Note: The feedback path measurement provided by the tool already includes the effects of transducers, acoustics, amplifiers and converter gains. Therefore, the MSG suggested by the tool applies only to the amplifier’s digital gain. This includes WDRC settings, volume control, wideband gain, graphic equalization, generic biquads, and a correction term that depends on the HRX setting.

For HRX on, 18 dB is automatically added to the digital gain by the IDS software. This 18 dB does not appear in the measured FB path. An 18 dB correction must be added to the measured data to correctly predict the maximum digital gain that can be added before feedback. If HRX is off, then 18 dB is removed from the digital gain and added to the microphone preamplifier. This 18 dB does appear in the measured FB path, so no digital gain correction is required. In other words, if the same instrument is measured once with HRX off and again with HRX on, then the two measurements will display an 18 dB gain difference.

For example, if the measured FB-path frequency response has a peak of -35 dB, then the maximum digital gain that can be applied before feedback is 35 dB. If HRX was on during the measurement, then the maximum IDS gain is 35 - 18, or 17dB; if HRX was off, the maximum IDS gain is 35 dB.

8.5 PRODUCT LIBRARY REQUIREMENTS

A product library must meet the following requirements to work properly with the FB Path Measurement Tool:

- The selected library and product must support the Tool (e.g., Inspiria SA3286 Demo Library and 8 Channel ITE/ITC 119/63, ALL Generic Biquads 32kHz product).
- The selected library must have Tinnitus Treatment enabled so that the Measurement Tool has a source of white noise.
• The Feedback Canceller and Acoustic Delay parameters must be enabled.
• The Post 3 Filter must be set to a Generic Biquad and its coefficients must be programmable.
• Either of the FE Modes (1 mic omni or rear only) must be enabled.
9.1 INTRODUCTION

The CalConfig software application for mARK2 enables the calibration and configuration of ON Semiconductor digital hearing instruments. The software uses a set of software building blocks called the Manufacturer's Application Resource Kit or mARK2. These building blocks work "behind the scenes" to perform device calibration using standard test equipment.

Figure 23 shows a typical connection of the test equipment. The fully completed shell of the hearing instrument is coupled to the Frye measurement microphone in the usual manner with a 2cc coupler, and connected to the programmer with an appropriate programming cable. Although this procedure can be adapted to work with any test equipment, it has been developed to work primarily with the following standard equipment:

- Frye FONIX 6500/7000 Hearing Instrument Test System equipped with the RS232 interface (earliest tested release of Frye firmware is version 4.21E)
- Interacoustics TBS25 (or similar B&K model) anechoic test chamber
- Programming box (e.g., HiPro, Microcard, ON Semiconductor DSP programmer)

The Interacoustics chamber is recommended over the Frye chamber as it provides better acoustic isolation. However, as long as an adequate signal-to-noise ratio is obtained, any test box will suffice. A minimum of 40 dB SNR is required to obtain 0.1 dB accuracy.

Figure 23: Typical Test Equipment Configuration
9.2 Setup

When you install ARKbase, the following shortcuts are created under **ON Semiconductor > ARK** in the Windows Start menu:

- Manufacturing Tools > CalConfig 2
- Configuration Tools >
  - Frye FONIX 6500 & 7000 Configuration
  - Workstation Manager

These applications are described in this chapter.

9.3 Configuration Tools

Before calibrating and configuring ON Semiconductor digital hybrids, learn about the configuration tools described below to ensure that the workstation setup and required interfaces are configured correctly.

9.3.1 Workstation Manager

The Workstation Manager is a software application that sets workstation specific options. To set up the default settings for a workstation:

1. Open the Workstation Manager from **ON Semiconductor > ARK > Configuration Tools** on the Windows Start menu.
2. Fill in the settings for the various workstation related options or click **Open File** to open and edit an existing .wrk file.
3. Click **Save Settings** to save all settings to a .wrk file.
4. Click **Exit** to close the program.

The options available in the Workstation Manager are shown in Figure 24. These options require some explanation:

- **Left Ear** or **Right Ear** indicates the default ear to communicate through.
- **Display calibration results** displays them in the instructions window of CalConfig.
- **The Configurations Directory** specifies where CalConfig will search for .ids files.
- **Show background** prevents you from seeing your desktop behind the CalConfig window.
- To store the calibration results, specify a path to the **Log File**.
- **Report Errors to Operator** can only be disabled if you choose **Log Results to File**.
- **Max Noise Level** is the maximum noise measure allowed before each calibration step takes place.
- **Stimulus level** is a composite signal that is applied by the stimulus device after calibration.

The .wrk file created in the Workstation Manager is then referenced in CalConfig using the /WorkFile command line parameter (see Section 9.5.3, “CalConfig Command Line Parameters” on page 76 for further details). To avoid using a command line parameter to access the .wrk file, save the file as worksetup.wrk in the same directory as CalConfig2.exe.
9.3.2 Frye Configuration Tool

Before performing calibration and configuration of ON Semiconductor digital hybrids, run the FONIX 6500/7000 Configuration Tool (see Figure 25) so that the CalConfig software application knows which COM port to use for communication with the FONIX 6500/7000, and what timeout value to use when communication occurs; otherwise, a communication failure occurs. The default value for the timeout is one second, and we recommend using this value unless communication errors occur.

To view the COM port, access the Control Panel from the Windows Start menu, and navigate to the Device Manager. Available COM ports are listed under Ports (COM & LPT). When the Frye FONIX 6500 & 7000 Configuration tool runs, you can specify the COM port through which the Frye will connect to the computer as well as the timeout that the Frye will use when transferring data. The COM port can be an integer value from 1 to 15 and the timeout must be a positive value in milliseconds.

9.4 CalConfig and the IDS

The calibration and configuration setup is completed within the IDS. The IDS also contains a scratch editor so that you can edit and save data to the configuration file.
To start the IDS, choose ON Semiconductor > ARK > Development Tools > Interactive Data Sheet from the Windows Start menu.

### 9.4.1 Calibration Setup in the IDS

To access the calibration setup, do the following:

1. Open the calibration setup section in the IDS from CalConfig > Setup… on the menu. Selecting this menu item opens a new dialog box with a series of tabs corresponding to the calibration options available for the selected product. For instance, an Inspiria product will have directional calibration options available while a Rhythm product will have trimmer calibration options available.
2. Select options in the calibration setup.
3. Press OK and save the .ids file. The calibration setup options are included in the saved .ids file.

#### 9.4.1.1 General Tab

All products have a General Calibration tab (see Figure 26) this tab enables the setup of general options for a product configuration. The general options include the following:

- **Configure Scratch Area**
  See Section 9.4.2, “Scratch Editor” on page 71 for more information.

- **Use Serial No. as first four bytes of scratch**
  You enter the serial number in the CalConfig application and it overwrites the first four bytes stored in the scratch editor.

- **Use control parameter values from Memory Configuration**
  Brings in the control data from the .ids file, if it exists, and burns it into the hearing instrument during the configuration process of CalConfig.

- **Set Active Memory to:**
  Use the drop-down list to set the active memory after the calibration process.

- **Configuration Type:**
  Enter a value that corresponds to a value in the Select Calibration Type drop-down list in CalConfig so this file will appear in the Select Configuration drop-down list when that option is selected in the Select Calibration Type.

  Calibration types can be defined in the ConfigFile.txt file located in the root directory, where ARK was installed. The default configuration types are BTE, ITE, ITC, CIC.
9.4.1.2 Sensitivity Tab

The sensitivity calibration setup options (see Figure 27) determine how to perform calibration of the input and output transducers. The sensitivity options include the following:

**Input type**
Selects the input transducer to be used for the sensitivity calibration.

**Calibrate Input & Output Sensitivities at (Hz):**
The source frequency to use when calibrating the transducers (specified in Hz).

**Receiver Correction Factor (dB):**
The receiver correction factor. This is specified in dB and will be subtracted from the receiver sensitivity when calibration is performed.

**Input Sensitivity and Output Sensitivity (dBV/dBSPL)**
The input and output sensitivity ranges. If the sensitivity measured falls outside of the respective transducer range, an error is reported and the calibration process stops.
9.4.1.3 Volume Control Tab

If your product does not require volume control calibration, this tab does not appear.

The volume control calibration setup (see Figure 28) determines whether or not to calibrate the external volume control. Selecting the calibrate volume control checkbox calibrates the volume control.

9.4.1.4 Telecoil Tab

The telecoil calibration setup (see Figure 29) determines how to perform calibration of the telecoil.
The telecoil options include the following:

**Calibrate Telecoil**
All other options on this tab become enabled once you select this.

**Prompt for reposition during Telecoil Calibration**
Some anechoic test boxes, such as the interacoustics box, have their magnetic coil located along the side of the box, rather than in the center where the hearing instrument is initially positioned for maximum acoustic pickup. Selecting this option stops the calibration process with a prompt for you to reposition the coil, then continue the process when you are ready.

**Telecoil Sensitivity (dBV/dBSPL)**
If the sensitivity measured falls outside of the specified range, an error is reported and the calibration process stops.

**Telecoil Gain**
Specify a gain in dB. It is subtracted from the telecoil sensitivity during calibration.

*Note:* To avoid calibrating the telecoil, specify an amount of gain to be applied in the telecoil path. You can set this up through ARKonline as a constant, or you can set the gain on a slider by using an application such as the IDS. The gain can be set anywhere from -10 to 23dB.

![Figure 29: Telecoil Tab](image)

### 9.4.1.5 Directional Tab

The directional calibration setup (see Figure 30) determines how to perform FrontWave® directional calibration.

The directional options include the following:
Calibrate directional system
   Enable the calibration of FrontWave. All other options on this tab become enabled once you select it.

Mic Spacing (mm):
   Specify the microphone spacing in millimeters.

Burn Mic Spacing Without Performing Mic Matching
   Burns in the selected microphone spacing value but does not perform the full FrontWave directional calibration.

Check Signal to Noise Ratio
   Enabling this option takes the difference between the measured noise floor and the signal level, and checks that it is greater than 40 dB. If the signal to noise ratio is below 40 dB, an error message is displayed and calibration of the directional system fails.

Expected Null Depth
   In this grid, enter the frequency and reduction pairs. After FrontWave calibration takes place, the hearing instrument is configured into bi-directional mode and the null depth is measured at the frequencies specified. This value is compared to the reduction value in the grid for the corresponding frequency. If the null depth is less than specified, an error is reported.

   Note: Every time you type a frequency and reduction pair into the grid, a new row appears allowing you to enter more data.

   To clear all the information in the grid, click Clear Null Depth.

Figure 30: Directional Tab
9.4.1.6 Trimmers Tab

The trimmer mode calibration setup (see Figure 31) determines how to configure trimmers.

The trimmer options include the following:

Enable the calibration of trimmers.
Only available for Foundation products.

Calibrate trimmers as two terminal or three terminal.
Only available for Foundation products.

Advanced Trimmer Options (3-terminal trimmers only)
Choose one of the following:

- Place trimmers at Vreg before configuration
- Place trimmers at GND before configuration (Recommended)
- Do not check trimmer connections

If you choose one of the first two options, the connected trimmers are checked at VREG or GND to ensure that they are functioning properly. Depending on the selection, position the wiper of the trimmer to the appropriate position before calibration and configuration. If the trimmer is not connected properly or the wiper is not positioned properly, an error message is displayed.

Enable second level verification on trimmer connections
Checks that multiple queries of the trimmer setting return consistent results. If the trimmer is not consistent, an error message is displayed.

Figure 31: Trimmers Tab
9.4.1.7 Acoustic Calibration Bypass

All calibration routines are performed acoustically by default. To change this, use the acoustic calibration bypass section (see Figure 32) by selecting the Tools > Acoustic Cal Bypass menu item on the Calibration Setup dialog box.

The options available are as follows:

**Skip full acoustic calibration by default**

The acoustic calibration and bypass mode are mutually exclusive (i.e., only one can be chosen for a configuration).

**Skip only telecoil acoustic calibration by default**

All selected acoustic calibration steps are performed except for the telecoil calibration.

**mic sensitivity:**

The microphone sensitivity (in dBV/dBSPL). This value is assigned to the part in place of the sensitivity that would be determined in the acoustic calibration.

**Assume device matches microphone model**

Selecting this checkbox sets the microphone sensitivity to 0 and this assumes that the microphone matches the model.

**rec sensitivity:**

The receiver sensitivity (in dBSPL/dBV). This value is similar to that of the microphone.

**Assume device matches receiver model**

This is similar to that of the microphone.

**tcoil sensitivity:**

The telecoil sensitivity (in dBV/dBSPL). This value is similar to that of the microphone.

**Assume device matches telecoil model**

Selecting this checkbox sets the telecoil sensitivity box to 0. The value burned into the part is assigned to 20 dB less than the sensitivity of the microphone.

*Note:* For telecoil calibration, the Calibrate Telecoil checkbox on the Telecoil tab (see Section 9.4.1.4, “Telecoil Tab” on page 66) must be selected for telecoil calibration to take place.
9.4.2 Scratch Editor

The scratch editor allows you to enter, edit and save data (such as serial numbers) on a device's EEPROM.

To open the scratch editor in the IDS, use the **CalConfig > Scratch Editor...** menu item. The scratch editor (see Figure 33) displays 128 bytes per page and shows as many pages as necessary to expose the number of bytes of scratch information that the chosen product can have. You can enter information in the scratch editor in binary, decimal, hexadecimal or ASCII.

If a connected device has been initialized in the IDS (you can use the **Programmer > Open, WhichChip, Init** menu option in the IDS), the **Read** and **Burn** buttons in the editor are enabled. Clicking them reads the device's scratch contents into the editor, or burns them from the editor, respectively. When a connected device's scratch memory is burned and the **Use Serial No. as first four bytes of scratch** is selected in the CalConfig Setup section (see Section 9.4.1.1, “General Tab” on page 64), the Serial No. text area will be burned to the part.

*Note:* The value entered for the serial number is only intended to be used when burning to an attached device. This value is not saved to the .ids file.

Once the data has been set in the scratch editor, clicking **OK** and saving the IDS configuration to a .ids file includes the scratch data. Alternately, opening up a .ids file fills the scratch editor with the contents of the file.
9.5 CalConfig

The CalConfig software application enables the calibration and configuration of ON Semiconductor digital hearing instruments.

To open the CalConfig application, choose ON Semiconductor > ARK > Manufacturing Tools > CalConfig 2 from the Windows Start menu. A window similar to Figure 34 appears.
9.5.1 Performing Calibration and Configuration

Calibration and configuration can be performed as follows:

1. In the Select Configuration Type box (see Figure 35), choose the configuration types to be displayed in the Select Configuration box. Those files which were saved with this configuration type (see the General tab of CalConfig in the IDS as described in Section 9.4.1.1, “General Tab” on page 64) are displayed in the Select Configuration box. The default is All Configurations.

2. In the Select Configuration box, choose the configuration file to use.

3. Enter a serial number if Use serial no, as first four bytes of scratch was selected in the configuration file; see Section 9.4.1.1, “General Tab” on page 64 to find out if it was selected. The serial number can range from 0 to 2,147,483,647.

4. If the product supports trimmers, select the trimmer assignments for this product. This is done using the drop-down boxes at the bottom of the CalConfig window. For information about how to configure your trimmers, refer to Section 5.7, “Trimmer Configuration” on page 31.

5. Click the Go button (it will become enabled at this point).

6. If applicable, make sure that the telecoil is pointed perpendicular to the magnetic field in the anechoic test box before beginning, or when prompted to do so.

7. Clicking Cancel at any time during the calibration and configuration process cancels the action. The program might not return control immediately because the system cannot interrupt a step that is in progress. The system will cancel the process after the step completes.

![Figure 35: CalConfig with Trimmer Display](image)

After each step is completed, a green check mark indicates that the step completed successfully (see Figure 36). If a step does not complete successfully, a red X appears. If Report Errors to Operator stayed selected in the Workstation Manager (see Section 9.3.1, “Workstation Manager”
on page 62 for details), then CalConfig stops and displays an error message. Otherwise, it displays the red X but continues the calibration and configuration process.

Upon completion, the pop-up box indicates that the process was successful and you can begin the process for another hearing instrument.

![Successful Calibration Example](image)

### 9.5.1.1 Calibration Setup

During calibration the software configures the device into different states to support the calibration steps selected. These settings are only written to the device and do not modify the EEPROM contents in the device. The final configuration burned to the device are the settings defined in the `.ids` file that was selected at run time.

### 9.5.1.2 After Configuration/Calibration

After calibration and configuration of the device is completed, a power cycle of the device is required to reset the values that were loading into RAM during the calibration setup.

### 9.5.2 Menus for CalConfig

This section describes all the menus available on CalConfig.

#### 9.5.2.1 File Menu

The File menu item contains two sub-menu items:
Refresh Files

Refreshes the Select Configuration drop-down list with the contents of the configuration directory because files created and saved in the IDS after CalConfig is opened will not be visible until Refresh Files is clicked.

Exit

Exits the CalConfig application.

9.5.2.2 Ear and Programmer Menus

Use the Ear and Programmer menus to select the right or left ear, and the type of programmer device. They are initially set to their respective values from the selected .wrk file (see Section 9.5.3, “CalConfig Command Line Parameters” on page 76). The currently selected programmer is also displayed in the upper right corner of the CalConfig application.

9.5.2.3 Memories Menu

The Memories menu contains options that allow you to skip over the configuration of selected memories. The number of memories available depends on how many memories are supported on the selected product. For example, if your product supports four memories, the Memories menu contains the following sub-menu items:

- Skip Mem A
- Skip Mem B
- Skip Mem C
- Skip Mem D

You can select more than one memory at a time.

9.5.2.4 Tools Menu

All the items in the Tools menu item become available once you specify a configuration in the Select Configuration field:

Read Trimmer Assignments and Levels

Reads the parameters that are assigned to each of the trimmers, and displays the level read based on the position of the trimmer on the connected device. This option is only available for trimmer-based products: Rhythm, Foundation and Consolidator.

Force Single Acoustic Cal

Forces acoustic calibration to take place on the next hearing instrument that is calibrated. This option is reset after the next calibration process. It is implemented so that a .ids file can be set to perform bypass acoustic calibrations, but the operator can still execute an acoustic calibration with the same file.

Check Calibration

Contains menu items relevant to the device described in the configuration file in the Select Configuration box. Clicking one of the check calibration options checks if the selected option is calibrated in the connected device. The results are returned in a message box.

Manual Calibration

Opens a dialog box that performs manual calibration. In the Manual Calibrate dialog box, select a calibration element and a series of input
parameters will be displayed for that element (see Figure 37). For example, clicking Input Sensitivity displays Raw Sensitivity in the Input Parameters box. Enter appropriate values for the input parameters and click Set after entering each parameter. Once all the parameters are assigned, click the GO button. The calibration element selected is programmed into the device.

Reset Factory Defaults

Resets all calibration parameters in the connected hearing instrument. This is useful when evaluating the benefits of calibration.

![Manual Calibration Dialog Box](image)

*Figure 37: Manual Calibration Dialog Box*

### 9.5.2.5 Help Menu

This menu provides information about the CalConfig application version, as well as identifies the type and version of the following:

- Current stimulus device
- Current measurement device
- Current programmer

### 9.5.3 CalConfig Command Line Parameters

CalConfig can be run with several command line parameters to enhance the capabilities of the application. To use the command line parameters, create a shortcut to CalConfig2 on the desktop. Right-click on the shortcut and select properties. Modify the target to add the desired command line parameter(s). For example, to use the /TreeStruct command line parameter, set the target to:

"C:\Program Files\ON Semiconductor\ARK\CalConfig2.exe" /TreeStruct

*Note:* The command line parameters are not case sensitive.
The command line parameters available for CalConfig are:

/NoLogo
Removes the ON Semiconductor logo from being displayed on startup.

/TreeStruct
Enables the tree structure selection setup for CalConfig (see Section 9.5.4, “Tree Structure” on page 77).

/SkipMemX
Skips burning memory X, where X = B, C, D. For example, to skip burning memory D use /SkipMemD.

/ShowMems
Displays a menu item that allows an operator to select which Paragon memories to skip without having to restart the application to specify a different set of /SkipMemX arguments. If the user runs the program with /SkipMemX arguments, those settings are the defaults that appear in the menu list. If no /SkipMemX arguments are included, then no memories will be skipped as default.

/WorkFile
Causes a dialog box to appear on CalConfig startup. Select a .wrk file created in the Workstation Manager.

/ForceAcoustic
Forces all calibration routines to be done acoustically (i.e., all acoustic bypass settings are ignored and the calibration routine is instead done acoustically).

/QuickConfigureChars=X
The maximum number of characters to allow in the quick configure box in tree structure mode. X is the maximum number of characters that can be entered. For example, to allow a maximum of five characters to be entered, use QuickConfigureChars=5.

9.5.4 Tree Structure

CalConfig can be run in default mode or in tree structure mode (see Figure 38). Tree structure mode allows operators to select configuration files based on defined criteria, rather than selecting the files from a list. The selected criteria will point to a configuration file.

To see the tree structure, run CalConfig from a command line with the /TreeStruct parameter as described in Section 9.5.3, “CalConfig Command Line Parameters” on page 76.
Figure 38: Default Tree Structure

The default tree structure has two selections (Product and Type), and two options (VC and Telecoil). An operator would select a product and then, based on the selected product, a set of types would be displayed in the type box. You can select yes or no, but depending on the selections in the Product and Type boxes, these options might not be applicable and will be disabled. For example, selecting FOUNDATION as the product and CIC as the type disables VC and Telecoil.

Once the selections are chosen, a file appears in the File Name box and Go becomes enabled. Calibration and configuration can proceed by clicking Go and the hearing instrument will be calibrated and configured with the file in the File Name box. If a configuration is not defined for the selected setting, a message box indicates that the selection is invalid.
Tree structure settings can also be chosen with the **Quick Configuration** box. Enter text into the **Quick Configuration** box. If the configuration is recognized, the tree structure is automatically assigned with associated values defined for the quick configuration. The default quick configuration definitions are located in the *TreeFileMap.txt* file in the root directory where ARK was installed. Refer to Section 9.5.4.1, “Customizing the Tree Structure” below for more information.

### 9.5.4.1 Customizing the Tree Structure

You can customize the tree structure layout to display different selection options by modifying the *TreeSelectors.txt* file located in the root directory where ARK was installed.

These characters are interpreted as special characters when they appear as the first character on a line:

- `%` (percent)
- `#` (hash)
- `*` (asterisk)

The `%` indicates that the line is a comment and should be ignored.

The `#` character defines a drop-down list in the tree structure which appears on the left side of the Settings area. These drop-down lists cannot be disabled, and depending on the value selected, they fill the following drop-down list with certain values. The value beside the `#` character indicates the field name that appears above the drop-down list. The following lines define the values and behavior of the drop-down list until another special character line is reached. For each of these lines, the first item on the line defines the value to add to the drop-down list. The
following tab-delimited items define what values appear in the following drop-down list when that item is selected.

Here is the default example provided in the TreeSelectors.txt file:

```
#Product
PARAGON BTE ITE ITC CIC
FOUNDATION BTE ITE ITC CIC
#Type
BTE
ITE
ITC
CIC
```

In this example, two drop-down lists are defined: **Product** and **Type**. **Product** has two items: PARAGON and FOUNDATION. **Type** has four items: BTE, ITE, ITC, and CIC. When CalConfig is run, only the **Product** drop-down list has values in it, the **Type** drop-down list is empty until a **Product** is selected. If PARAGON is selected, the **Type** drop-down list is filled with BTE, ITE, ITC, and CIC.

The * character defines a drop-down list in the tree structure that appears on the right side of the settings area. These drop-down lists always have values appear in them but can be disabled by the drop-down lists on the left.

*Note:* The * drop-down lists can only be defined in the file after all # drop-down lists are defined. The value beside the * character indicates the name that appears above the drop-down list. The following tab-delimited items define what combinations of the # drop-down lists will disable the drop-down list. The combinations must be comma-delimited values, and list as many values as the number of # drop-down lists. If all selections of a # drop-down list make the * drop-down list disabled, use the * wildcard character.

The following lines define the values of the drop-down list until another special character line is reached:

```
*VC *,CIC
Yes
No
*Telecoil *,CIC
Yes
No
```

In this example, two drop-down lists are defined: VC and Telecoil. Both of these drop-down lists are disabled when any **Product** is selected and the **Type** is set to **CIC**. If this were only true when **PARAGON** was selected, the lines would be:

```
*VC PARAGON,CIC
... *Telecoil PARAGON,CIC
```

*Note:* More than one definition to disable the drop-down list can be applied but further definitions must be tab-delimited on the same line. Both of these drop-down lists have two values: Yes and No.
9.5.4.1.1 Tree Selection and File Association

Once the tree structure is customized, the selections must be assigned to associated .ids files. The TreeFileMap.txt file, located in the root directory where ARK was installed, specifies the file associations. When a percent sign (%) appears as the first character on a line, the line is interpreted as a comment and is ignored. All other lines define file associations from selections as follows, where each value is tab-delimited:

1. Specify the drop-down list selections, in the order that they are defined in the TreeSelectors.txt file.
2. Specify the associated .ids file.
3. Specify the quick configure text.

For example:

PARAGON ITC  No  No Paragon.ids PAR_ITC
PARAGON CIC  -  -  Paragon.ids PAR_CIC
FOUNDATION BTE  Yes  Yes Foundation.ids FOUN_BTE_V_T

In this example, if Product is PARAGON, the Type is ITC, the VC is No, and the Telecoil is No, then Paragon.ids is the file that is used to configure the hearing instrument. Entering PAR_ITC in the Quick Configure box in CalConfig also brings up the defined configuration file.

In the second definition, the VC and Telecoil are assigned to “-” because these options are disabled in that configuration.

Note: If a configuration is selected and no file association is found, a warning message will be displayed indicating that a file was not found for the given association.

To help with the construction of these files, we recommend using a spreadsheet to create these files using different cells for tab-delimited values. Save the file as a tab-delimited ASCII text file in the names and locations provided.
This page left blank for printing purposes.
10.1 INTRODUCTION

ARKonline is a web-based tool that allows hearing instrument manufacturers to customize and build product component libraries. These libraries will consist of one or more products, and each product in the library will have a microphone, a receiver and a map associated with it. Maps contain the configurable parameters in a product. With the ARKonline map wizard you can design customized maps to use in your libraries.

10.2 ARKonline Membership

Registering for an Account

To use ARKonline, first register for an account:

2. Click on Register in the menu on the left.
3. Fill out the Registration Information on this page and click Register at the bottom of the page. The email address you provide is where you will receive confirmation of your registration and your password.
4. An account will be set up for you within two working days after receiving your application.

Logging into ARKonline

Once you have received an email confirming your registration and providing a password:

2. To login to ARKonline, click Login in the menu on the left.
3. Fill in the user name that you created and the password that you received in the email.
4. If you would like to change your password, click Preferences and enter a new password.

Note: To leave ARKonline, close the browser or navigate to another page and you are automatically logged out.

Resetting a Lost Password

If you have forgotten the password associated with your ARKonline account, you can reset your password through the ARKonline site:

1. Click Lost Password in the menu on the left of the ARKonline homepage.
2. You are prompted for your username and email address. To reset your password, you must know the email address associated with your ARKonline account and have access to this email account.
3. Click Send Email. An email will be sent to the email associated with your ARKonline account with instructions for completing the password reset.
10.3 LIBRARIES

Product component libraries can be customized and built using ARKonline. These libraries contain multiple products, that each have transducers (microphones and receivers) and parameter maps associated with them. The following sections describe how to create these libraries, and then how to make use of these libraries in our ARK-based software tools.

10.3.1 Creating a Library

To create a library:

1. Click **Library Manager** in the menu on the left to enter the ARKonline Library Manager.
2. Click **Libraries** and you see the LIBRARIES page, similar to the illustration in Figure 40.

![Figure 40: The List of Available Libraries on the LIBRARIES Page](image)

3. Click on **Create New Library** to begin creating a library. A page similar to Figure 41 appears.
4. Enter the **Library (DLL) Name**. This name will be the name of the DLL.
5. Enter the **Library Title**. The title of the library can be more descriptive. This title will appear in the tables on the LIBRARIES page and in the Library drop-down box in IDS.
6. **Comments** is an optional field.
7. Enter a **Version** number for this library.
8. The **Library ID** is an automatically generated sequential number that uniquely identifies the library within your company. You can leave the number as is or change it. The random library ID is generated by querying the list of libraries already created by the customer and determining an unused value. Using the library ID that is randomly generated is the best way to ensure that multiple libraries on your system do not have the same library ID.
9. Select one or more desired platforms for which the library will be used by clicking the appropriate checkboxes.
10. Under **Permissions**, define other people’s access to this library. See Section 10.6.1, “Setting Permissions” on page 98 for details.
11. Click Create Library. You are sent to the EDIT LIBRARY page (see Figure 42 on page 86) where you can edit the library information as well as add products to the library.

![ARKnline](image)

<table>
<thead>
<tr>
<th>NEW LIBRARY</th>
</tr>
</thead>
<tbody>
<tr>
<td>Library (DLL) Name:</td>
</tr>
<tr>
<td>Library Title:</td>
</tr>
<tr>
<td>Comments:</td>
</tr>
<tr>
<td>Version: 1.0.0</td>
</tr>
<tr>
<td>Library ID: 2</td>
</tr>
<tr>
<td>Manufacturer ID: 0</td>
</tr>
</tbody>
</table>

**Platforms:**

<table>
<thead>
<tr>
<th>Platform</th>
<th>Verified</th>
<th>Device</th>
</tr>
</thead>
<tbody>
<tr>
<td>Win32</td>
<td>Yes</td>
<td>N/A</td>
</tr>
<tr>
<td>PocketPC ARM</td>
<td>Yes</td>
<td>Casio PAQ 3550</td>
</tr>
<tr>
<td>PocketPC MIPS</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>PocketPC SH3</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>PocketPC Linux</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>hPc Ver. 2.00 MIPS</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>hPc Ver. 2.00 SH3</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>hPc Pro 2.11 MIPS</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>hPc Pro 2.11 SH3</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Palm-size PC 2.11 MIPS</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Palm-size PC 2.11 SH3</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Casio BE-300</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Platforms that have not been verified may still work. If you need support for a particular device, e-mail software@sounddev.com.

**Permissions:**

- Allow other people in my company to view this Item.
- Allow other people in my company to edit this Item.

Create Library

**Figure 41: Creating a New Library**

### 10.3.2 Adding a Product to a Library

Perform the following procedure from the EDIT LIBRARY page, which is illustrated in Figure 42. To find out how to get to this page, see one of the following:

- Section 10.3.1, “Creating a Library” on page 84
- Section 10.3.5, “Copying a Library” on page 87
- Section 10.3.6, “Editing a Library” on page 88
Figure 42: Editing a Library and its Products

1. To add the first product, click Add Product which is located at the top right of the table titled Products in This Library. This adds an empty entry to the table.

2. Fill in the Product Name and Product Title fields in the product table. The two blank fields in the products table under Max Gain and Max Output will be calculated for you later.

3. Select a microphone, a map and a receiver for this product. Clicking Select a Microphone under the heading Microphone shows you a new page with a list of microphones to choose. To learn how to add your own microphones, refer to Section 10.5, “Microphones and Receivers” on page 93.

4. Click Select to the right of the microphone that you want. This returns you to the EDIT LIBRARY page for the library that is currently being edited. Notice that the name of the microphone that you just selected appears under the Microphone heading.

5. Repeat the above for selecting a map and a receiver. Refer to Section 10.5, “Microphones and Receivers” on page 93 and Section 10.4.1, “Creating a Map” on page 89 for information about creating maps and receivers.

6. Notice that the Max Output and Max Gain have been calculated and added to the table for this product.
   - Max Output: The maximum output of the receiver.
   - Max Gain: The sum of the maximum gain of the transducers, the maximum gain of the device based on the parameter settings, and the converter gain which is always 30 dB.

7. To add more products, click Add Product and repeat the above steps.

8. When you have finished editing the library, click Save at the top of the page and you return to the LIBRARIES page.

9. Click View next to the library that was just edited and you see a summary of the information about this library.
10.3.3 Building a Library

When a library is built, the DLL and code for the library are generated automatically and made available for you to download. If you have finished creating and adding products to your library, now you can build it.

1. Navigate to the LIBRARIES page (shown in Figure 40 on page 84), if you are not already there. From the Home page, you can choose Library Manager > Libraries.
2. Click Edit next to the library that you would like to build. You are now at the EDIT LIBRARY page (shown in Figure 42 on page 86).
3. Click Build in the menu at the top of the page. A warning displays for any unsaved microphones, maps or receivers in the library. Refer to Section 10.6.2, “Saved vs. Unsaved Items” on page 99 for an explanation of the difference between saved and unsaved maps, receivers, and microphones. You are returned to the LIBRARIES page.
4. Locate your library in the My Libraries table; the status of the library is marked as Pending.
5. When the library finishes building the status changes to Built. To check the status of the library, click the Refresh button on the top toolbar of the web browser. In Internet Explorer, you can refresh the screen by pressing F5 on the keyboard.
6. You can download the DLL for the library you just built by clicking Download next to the title of the library. (The download source feature is deprecated.) Remember where you have downloaded it so that you can find it when you want to register it as described in Section 10.3.4, “Registering a Library” on page 87.

**Note:** If you edit this library, you cannot download this version of the DLL, and you will have to build the library again. Therefore, if you click Edit, a message pops up to confirm that you really want to edit this library. If you continue to the EDIT LIBRARY page, clicking Abort will undo any changes and allow you to download the DLL without building the library again.

10.3.4 Registering a Library

After downloading the DLL, you must register it to be used in the Interactive Data Sheet. To simplify this process, ARKbase comes with a program called the ARK Component Manager. For instructions on registering a library using the ARK Component Manager, refer to Section 5.4.2, “Selecting a Library to Install” on page 18.

10.3.5 Copying a Library

Instead of creating all libraries from scratch, you can copy existing libraries, whether it is a library that you previously created, a library that someone else in your company created, or any of the public libraries. When a library is copied, all the products that are in this library are copied as well.

To copy a library:

1. Navigate to the LIBRARIES page (shown in Figure 40 on page 84), if you are not already there. From the Home page, you can choose Library Manager > Libraries.
2. Identify the library that you want to copy and click Copy to the right of that library title. This displays the EDIT LIBRARY page (shown in Figure 42 on page 86). All the information from the library that you selected is copied, and now you are editing it.
3. Enter a new library name and library title for the library you just copied. Library titles must be unique for each user.
4. Now you can edit this library the same way you would edit a library that you created. Refer to Section 10.3.6, “Editing a Library” below for details.
10.3.6 Editing a Library

After you create a library with ARKonline, you can edit or view this library at any time. To edit a library:

1. Navigate to the LIBRARIES page (shown in Figure 40 on page 84), if you are not already there. From the Home page, you can choose Library Manager > Libraries.
2. Click Edit to the right of the library to edit. Now you see the EDIT LIBRARY page (shown in Figure 42 on page 86). All the information about the library is displayed on this page.
3. On this page you can change the information about the library, or edit any of the products in this library. If you change the library title, remember that it must be unique to you.
4. To change the map that you selected for one of the products in this library, click the map name next to the product you are editing. This shows you the SELECT MAP page (see Figure 43). The map that you currently have selected is highlighted in blue. To change the selected map, click Select next to your new choice for the map. You are returned to the EDIT LIBRARY page.

5. Changing the selected microphone or receiver is the same process as described for the map.
6. To add more products to this library, click Add Product at the top of the Products table on the EDIT LIBRARY page. To remove products, click Delete next to the product you would like to delete.
7. When you have finished making changes to this library you can do one of the following:
   - Save: Saving the library returns you to the LIBRARIES page. The library that you just edited will be in the My Libraries table highlighted in gray to identify it as a saved
library. (If unsaved microphones, receivers or maps are associated with any products in this library, an error is displayed notifying you which items must be saved before continuing.)

- **Build**: Generates the DLL for the library. (If unsaved microphones, receivers or maps are associated with any products in this library, an error is displayed notifying you which items must be saved before continuing.) Refer to Section 10.3.3, “Building a Library” on page 87 for more information.

- **Abort**: Undoes all the changes that were made to this library. You can only abort a library if a previous version was saved. An error message is displayed to notify you if it is not possible to Abort to a previous version.

Clicking any of these buttons returns you to the LIBRARIES page. You can also leave the EDIT LIBRARIES page without clicking any of these buttons, and your changes will still be there when you return.

8. If you created the library you are editing, the library is now in the **My Libraries** table. If someone else in your company created the library, you will see it in the table **Company Libraries**, where **Company** is the name of the company associated with your ARKonline user account. Unsaved libraries are highlighted in yellow, and saved libraries are highlighted in grey.

### 10.3.7 Viewing a Library

If you want to view a library without making any changes to it:

1. Navigate to the LIBRARIES page (shown in Figure 40 on page 84), if you are not already there. From the Home page, you can choose **Library Manager > Libraries**.

2. Click **View** next to the library. This gives you a summary of the information about this library, including a list of the products in this library, and their components.

3. Click **Libraries** to return to the LIBRARIES page to view another library.

### 10.4 Maps

ARKonline allows you to create your own maps to be used in your product component libraries. To customize maps to suit your product needs, use one of the ARKonline wizards. An ARKonline wizard is available for each ON Semiconductor preconfigured DSP product.

#### 10.4.1 Creating a Map

Do the following to create a map:

1. Navigate to the MAPS page (shown in Figure 44). From the Home page, you can choose **Library Manager > Maps**.

2. Click **Maps** in the menu bar on the left. This brings you to the MAPS page with a table of maps that you already created under the heading **My Maps**.

3. Click **Create New Map** at the top of the page. This launches the online wizard for creating maps.

4. Select the Wizard that supports the product that you would like to customize and click **Next**.

5. Fill out the page with the information about the new map you are going to create. For more information about the permissions you can grant, see Section 10.6.1, “Setting Permissions” on page 98. When you are finished, click **Create Map**.
6. Edit the individual parameters of your map. You can either navigate through the wizard sequentially, or use the highlighted menu on the left with a direct link to a specific group of parameters. (See Figure 45 for an example of the navigation buttons and the menu.) Each parameter is initially filled with a set of default names and values. You can change this information or leave the default values. Whether you use the navigation buttons or the direct links, any parameter settings you modified are recorded.

IMPORTANT: Do not use the browser’s Back button to navigate between pages because you risk losing your changes.

7. At any time, you can navigate away from these pages or click the Save button. Your changes will not be lost. For an explanation of the difference between saved and unsaved maps, see Section 10.6.2, “Saved vs. Unsaved Items” on page 99.
10.4.2 Copying a Map

The Copy link on the MAPS page allows you to copy an existing map. You can copy saved maps that you have created, maps that other people in your company have created, or any of the public maps. To copy a saved map:

1. Navigate to the MAPS page (shown in Figure 44 on page 90). From the Home page, you can choose Library Manager > Maps.
2. Click Copy beside the map that you would like to copy.
3. Change the map information from the map you are copying to the information about your new map. The map name must be updated. An error message is displayed if the map name matches an existing map that you created. The map title appears on the list of maps, so you might want to change this as well to avoid confusion.
4. You can now edit this map in the same way as described in Section 10.4.3, “Editing a Map”. The default values in this map are the same as the map that you copied.

10.4.3 Editing a Map

To edit a map:
1. Navigate to the MAPS page (shown in Figure 44 on page 90). From the Home page, you can choose Library Manager > Maps.

2. Click the Edit link. This displays the MAP SUMMARY page. The page contains a summary of the information about that map, including the map name, title, and parameter values. See Figure 46 for an example. Notice that it has the name of the wizard in the top right corner.

![Figure 46: A Map Summary Page for Editing](image)

3. If you want to edit the map name, title, version or permissions, you can type the new information into the text boxes at the top of the page.

4. Move your mouse over the links on the left to see a summary of the details for each parameter displayed in the Parameter Details box.

5. If you want to edit any of the values for the parameters, click on the individual parameter links to open the corresponding page in the map wizard. Alternatively, use the menu on the left to directly open a particular page in the wizard. For more information about the parameters, see the Parameters information note for your product.

6. You can use the Next and Previous links at the top or bottom of the page to proceed through the wizard, or use the highlighted menu on the left to go directly to one of the parameters.

7. To return to the map summary (shown in Figure 46 above), click Map Summary in the menu on the left.

8. If you have finished editing this map you can do one of the following:
   - **Save**: This action returns you to the MAPS page. The map that you just edited will appear in the My Maps table highlighted in gray because it is a saved map.
   - **Abort**: Undoes all changes that were made to this map. It returns you to the previously saved version of this map. You can only abort a map if a previously saved version exists.
   - Simply leave this page. Your changes are still preserved. On the MAPS page, this map will be highlighted in yellow to indicate that it is an unsaved map.
10.4.4 Viewing a Map

To view a map without making changes:

1. Navigate to the MAPS page (shown in Figure 44 on page 90). From the Home page, you can choose Library Manager > Maps.
2. Click View next to the map you want to examine. The window looks very similar to the MAP SUMMARY page shown in Figure 46 on page 92 except that none of the fields are editable.
3. Move your mouse over the parameter names on the left to see a summary of the parameter values in the Parameter Details box.
4. To see all the parameters and their specific settings, click View Complete Report at the top of the page. From this page, you can generate a printable report by clicking View the printable version of this report. You will have to use the back button on your browser to navigate away from this page.
5. If you want to return to the MAPS page to view another map, click Maps in the menu on the left.

10.5 MICROPHONES AND RECEIVERS

The processes for adding, copying, viewing and editing a microphone or receiver are exactly the same. The descriptions below use microphones as an example.

10.5.1 Adding a Microphone or Receiver

To add a microphone or receiver to a library, do the following (for receivers, just substitute Receivers wherever you see Microphones):

1. Navigate to the MICROPHONES page (shown in Figure 47). From the Home page, you can choose Library Manager > Microphones.
2. Click **Add New Microphone** at the top of the page. This displays the page that you must fill out with the information about the microphone to be added. See Figure 48 for an example.
3. Notice that the text box at the bottom of the page must be filled with the measured sensitivity data for the microphone. You can copy and paste this information from the Modeler application. Refer to Section 6.4, “Microphone Measurement” on page 38 for a description of how to obtain this data.

4. When you have finished entering all the required information, click **Save Microphone** and you return to the MICROPHONES page.

   Note: Your information is not saved if you navigate away from this page without clicking **Save Microphone**.

5. Now you can select this microphone to be used with products in a library.

### 10.5.2 Copying a Microphone or Receiver

To copy a microphone or receiver, do the following (for receivers, just substitute **Receivers** wherever you see **Microphones**):

1. Navigate to the MICROPHONES page (shown in Figure 47 on page 94). From the Home page, you can choose **Library Manager > Microphones**.
2. Click **Copy** next to the microphone that you would like to copy.
3. Change information about this microphone as necessary.
4. Click **Save** to return to the MICROPHONES page. If you navigate away from this page without saving, the information is still preserved. The microphone is listed in tables with yellow highlighting to show that it is unsaved. See Section 10.6.2, “Saved vs. Unsaved Items” on page 99 for an explanation of the difference between saved and unsaved microphones and receivers.

### 10.5.3 Editing Microphones and Receivers

To edit a microphone or receiver, do the following (for receivers, just substitute **Receivers** wherever you see **Microphones**):

1. Navigate to the MICROPHONES page (shown in Figure 47 on page 94). From the Home page, you can choose **Library Manager > Microphones**.
2. Click **Edit** next to the microphone. The **EDIT MICROPHONE** page will look similar to Figure 49. Notice that the graph of the sensitivity data appears above the data points.

---

**EDIT MICROPHONE**

<table>
<thead>
<tr>
<th>Save</th>
<th>Abort</th>
<th>Undo</th>
</tr>
</thead>
</table>

- **Microphone Name**: Microphone3
- **Comments**: 
- **Version**: 1.00
- **Permissions**: 
  - Allow other people in my company to view this item.
  - Allow other people in my company to edit this item.
- **Manufacturer**: JBL
- **Application**: JBL

**Microphone Sensitivity 0-8 DBSPL**

Input: 
- 0 @DBSPL
- 1 @db
- 1 @Pascal

### Sensitivity Data:

<table>
<thead>
<tr>
<th>Frequency (Hz)</th>
<th>Sensitivity (DBSPL)</th>
</tr>
</thead>
<tbody>
<tr>
<td>16</td>
<td>-137.6</td>
</tr>
<tr>
<td>14.6</td>
<td>-137.6</td>
</tr>
<tr>
<td>17.6</td>
<td>-137.5</td>
</tr>
<tr>
<td>18</td>
<td>-137.4</td>
</tr>
<tr>
<td>20</td>
<td>-137.4</td>
</tr>
<tr>
<td>21.2</td>
<td>-137.3</td>
</tr>
<tr>
<td>22.4</td>
<td>-137.2</td>
</tr>
<tr>
<td>23.7</td>
<td>-137.1</td>
</tr>
<tr>
<td>25</td>
<td>-137.1</td>
</tr>
<tr>
<td>26.8</td>
<td>-137.0</td>
</tr>
</tbody>
</table>

---

**Figure 49: Editing a Microphone**
3. You can change any of the information on this page, except you cannot directly edit the graph.

4. When you are finished making changes to this microphone you can do one of the following:
   - **Save**: This action returns you to the MICROPHONES page. The microphone that you just edited will be in the My Microphones table.
   - **Abort**: Undoes all changes that were made to this microphone. You can only abort a microphone if a previously saved version exists.
   - **Undo**: Undoes the changes that you made to this page.
   - Simply leave this page. Your changes are still preserved. On the MICROPHONES page, this microphone will be highlighted in yellow to indicate that it is an unsaved microphone.

### 10.5.3.1 Viewing a Microphone or Receiver

To view a microphone or receiver without making changes, do the following (for receivers, just substitute Receivers wherever you see Microphones):

1. Navigate to the MICROPHONES page (shown in Figure 47 on page 94). From the Home page, you can choose Library Manager > Microphones.
2. Click View next to the microphone that you would like to examine. A window such as the one in Figure 50 is displayed.

![Figure 50: Viewing Microphone Information](image)

To save data in a format that can be opened using the Modeler application:

1. Click the Copy XML Data to Clipboard button below.
2. Open Notepad and paste data.
3. Save the file with the extension .xml.

3. Notice that you can save the sensitivity data in a file for use in the Modeler application. The instructions for saving the data are on the VIEW MICROPHONES page. To learn more about using the data file, see Section 6.4, “Microphone Measurement” on page 38.
4. You can change the units used to display the data on the graph by selecting a different Input.
5. If you want to return to the MICROPHONES page to view another microphone, click Microphones in the menu on the left.

10.6 ADDITIONAL FEATURES

10.6.1 Setting Permissions

ARKonline allows you to set permissions for libraries, and for each of the components of a product in a library: microphones, receivers and maps. The permissions you select determine if other employees in your company can view or edit these items on the list pages. Libraries and the components each have a list page which consists of a search field and tables listing either the libraries, microphones, receivers or maps (see Figure 47 on page 94 for an example of a list page). You can have up to three tables on each of the list pages. The structure described below uses maps as an example, but all the list pages are structured the same way.

Permission options available for libraries, maps, microphones and receivers are:

**Allow other people in my company to view this item**
Other ARKonline users in your company can view the items you have created, but they cannot make changes to these items.

**Allow other people in my company to edit this item**
Other ARKonline users in your company can view and edit any items that you have created and saved.

My Maps

The table titled My Maps, for example, contains the maps that you created. If one of the maps that you have created is currently being edited, the item is highlighted in yellow. When you were creating your map, if you set permissions as Allow other people in my company to edit this item, others in your company can edit this map after you save it. When other people in your company are editing items you created, the name of the person in your company who is editing this item appears below the item.

Company Maps

The second table has the same name as the name of your company and contains the items that other people in your company have created. Other people using ARKonline cannot see these maps; only employees in your company registered with ARKonline have access to these. If you are editing items that were created by other employees in your company, they are displayed in this table. The name of the employee who created this item appears below the company item you are editing. If you set the permissions on your map to Allow other people in my company to view this item, the map displayed in this table does not have an Edit link beside it. If you do not select either of the permissions, the map is not displayed in this table at all.

Public Maps

The third table contains items that have been made public. All ARKonline users can view or copy these items.
10.6.2 Saved vs. Unsaved Items

The four items in the Library Manager—libraries, microphones, receivers and maps—can all have items in them that will be classified as *saved* or *unsaved*. On each of these four pages, a legend at the top of the page explains which items are saved and which are unsaved. The table rows highlighted in yellow are unsaved items and the gray rows are saved. When an item is unsaved, the revision of this item is still being edited. This item can be left unsaved for as long as you would like. You will not lose your changes if you leave the ARKonline site. However, if you would like someone else in your company to be able to edit this item, you will have to save it. When the item is saved, it means that this revision of the item has been closed. To edit this item again you must open it by clicking **Edit** again, which opens another revision of the item.

Two types of items that you can edit are saved items and unsaved items. When you edit a saved item, a copy of this item is made and stored. This allows you to Abort to the saved version of the item at any time during the editing session if needed. When you edit an item that is unsaved, you cannot revert to a previous version. You can only abort to a saved version of the item if one exists.